Re: [PATCH 3/6] crypto: ccp: Move some PSP mailbox bit definitions into common header

From: Jan Dąbroś
Date: Tue Feb 14 2023 - 04:05:34 EST


(...)
> @@ -99,7 +93,7 @@ static int psp_check_mbox_recovery(struct psp_mbox __iomem *mbox)
>
> tmp = readl(&mbox->cmd_fields);
>
> - return FIELD_GET(PSP_MBOX_FIELDS_RECOVERY, tmp);
> + return FIELD_GET(PSP_CMDRESP_RECOVERY, tmp);
> }
>
> static int psp_wait_cmd(struct psp_mbox __iomem *mbox)
> @@ -107,7 +101,7 @@ static int psp_wait_cmd(struct psp_mbox __iomem *mbox)
> u32 tmp, expected;
>
> /* Expect mbox_cmd to be cleared and ready bit to be set by PSP */
> - expected = FIELD_PREP(PSP_MBOX_FIELDS_READY, 1);
> + expected = FIELD_PREP(PSP_CMDRESP_RESP, 1);

What's the meaning of "PSP_CMDRESP_RESP"? I see that this new macro
name is currently used by other drivers, but in my opinion "READY" is
more descriptive. (It is also aligned to the comment above this line.)