Re: [PATCH 3/4] selftests/resctrl: Change name from CBM_MASK_PATH to INFO_PATH

From: Ilpo Järvinen
Date: Wed Feb 08 2023 - 09:05:38 EST


On Wed, 8 Feb 2023, Ilpo Järvinen wrote:

> From: "Signed-off-by: Fenghua Yu" <fenghua.yu@xxxxxxxxx>

I seem to have managed to do a little copy paste error there. I can
resubmit the series if needed.

--
i.

> CBM_MASK_PATH is actually the path to resctrl/info, so change the macro
> name to correctly indicate what it represents.
>
> Signed-off-by: Fenghua Yu <fenghua.yu@xxxxxxxxx>
> ---
> tools/testing/selftests/resctrl/resctrl.h | 2 +-
> tools/testing/selftests/resctrl/resctrlfs.c | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/tools/testing/selftests/resctrl/resctrl.h b/tools/testing/selftests/resctrl/resctrl.h
> index f0ded31fb3c7..4f0976f12634 100644
> --- a/tools/testing/selftests/resctrl/resctrl.h
> +++ b/tools/testing/selftests/resctrl/resctrl.h
> @@ -28,7 +28,7 @@
> #define MB (1024 * 1024)
> #define RESCTRL_PATH "/sys/fs/resctrl"
> #define PHYS_ID_PATH "/sys/devices/system/cpu/cpu"
> -#define CBM_MASK_PATH "/sys/fs/resctrl/info"
> +#define INFO_PATH "/sys/fs/resctrl/info"
> #define L3_PATH "/sys/fs/resctrl/info/L3"
> #define MB_PATH "/sys/fs/resctrl/info/MB"
> #define L3_MON_PATH "/sys/fs/resctrl/info/L3_MON"
> diff --git a/tools/testing/selftests/resctrl/resctrlfs.c b/tools/testing/selftests/resctrl/resctrlfs.c
> index 6f543e470ad4..cc6cf49e3129 100644
> --- a/tools/testing/selftests/resctrl/resctrlfs.c
> +++ b/tools/testing/selftests/resctrl/resctrlfs.c
> @@ -210,7 +210,7 @@ int get_cbm_mask(char *cache_type, char *cbm_mask)
> if (!cbm_mask)
> return -1;
>
> - sprintf(cbm_mask_path, "%s/%s/cbm_mask", CBM_MASK_PATH, cache_type);
> + sprintf(cbm_mask_path, "%s/%s/cbm_mask", INFO_PATH, cache_type);
>
> fp = fopen(cbm_mask_path, "r");
> if (!fp) {
>