Re: [PATCH v4 4/7] mm: replace vma->vm_flags direct modifications with modifier calls

From: Suren Baghdasaryan
Date: Tue Jan 31 2023 - 16:08:38 EST


On Tue, Jan 31, 2023 at 12:54 PM Andrew Morton
<akpm@xxxxxxxxxxxxxxxxxxxx> wrote:
>
> On Tue, 31 Jan 2023 10:54:22 -0800 Suren Baghdasaryan <surenb@xxxxxxxxxx> wrote:
>
> > > > - vma->vm_flags &= ~VM_MAYWRITE;
> > > > + vm_flags_clear(vma, VM_MAYSHARE);
> > > > }
> > >
> > > I think it should be:
> > > s/VM_MAYSHARE/VM_MAYWRITE/
> >
>
> I added the fixup. Much better than resending a seven patch series for a
> single line change. Unless you have substantial other changes pending.

Thanks! That sounds reasonable.

I'll also need to introduce vm_flags_reset_once() to use in
replacement of WRITE_ONCE(vma->vm_flags, newflags) case. Should I send
a separate short patch for that?

>
> --
> To unsubscribe from this group and stop receiving emails from it, send an email to kernel-team+unsubscribe@xxxxxxxxxxx.
>