Re: [PATCH v2 0/6] arm64/signal: Signal handling cleanups

From: Catalin Marinas
Date: Tue Jan 31 2023 - 07:51:54 EST


Hi Mark,

On Tue, Jan 03, 2023 at 08:25:15PM +0000, Mark Brown wrote:
> This series collects a number of small cleanups to the signal handling
> code which removes redundant validation of size information and avoids
> reading the same data from userspace twice.
>
> There are some overlaps with both the TPIDR2 signal handling and SME2
> serieses which are also in flight, applying this will require
> adjustments in those serieses and vice versa.
[...]
> Mark Brown (6):
> arm64/signal: Don't redundantly verify FPSIMD magic
> arm64/signal: Remove redundant size validation from parse_user_sigframe()
> arm64/signal: Make interface for restore_fpsimd_context() consistent

I'm fine with the first three patches, they seem correct and make the
frame checking more consistent.

> arm64/signal: Avoid rereading context frame sizes
> arm64/signal: Only read new data when parsing the SVE context
> arm64/signal: Only read new data when parsing the ZA context

I'm not sure these add much to the code readability (and the performance
improvement I guess is negligible). We avoid some copy_from_user() into
the context structures but rely on data read previously or some
get_user() into local variables. Personally I'd make the
restore_fpsimd_context() also do a copy_from_user() for consistency with
the current sve and za frames restoring.

Personal preference, not sure whether Will has the same view.

--
Catalin