Re: [PATCH] [v3] wiznet: convert to GPIO descriptors

From: Rob Herring
Date: Mon Jan 30 2023 - 14:14:25 EST


On Fri, Jan 27, 2023 at 10:57:08AM +0100, Arnd Bergmann wrote:
> From: Arnd Bergmann <arnd@xxxxxxxx>
>
> The w5100/w5300 drivers only support probing with old platform data in
> MMIO mode, or probing with DT in SPI mode. There are no users of this
> platform data in tree, and from the git history it appears that the only
> users of MMIO mode were on the (since removed) blackfin architecture.
>
> Remove the platform data option, as it's unlikely to still be needed, and
> change the internal operation to GPIO descriptors, making the behavior
> the same for SPI and MMIO mode. The other data in the platform_data
> structure is the MAC address, so make that also handled the same for both.
>
> It would probably be possible to just remove the MMIO mode driver
> completely, but it seems fine otherwise, and fixing it to use the modern
> interface seems easy enough.
>
> The CONFIG_WIZNET_BUS_SHIFT value was apparently meant to be set
> at compile time to a machine specific value. This was always broken
> for multiplatform configurations with conflicting requirements, and
> in the mainline kernel it was set to 0 anyway. Leave it defined
> locally as 0 but rename it to something without the CONFIG_ prefix.
>
> Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx>
> ---
> v3: include linux/gpio/consumer.h to avoid build failure without GPIOLIB
> v2: replace CONFIG_WIZNET_BUS_SHIFT with a constant
>
> Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx>
> ---
> .../devicetree/bindings/net/wiznet,w5x00.txt | 4 +-

Acked-by: Rob Herring <robh@xxxxxxxxxx>

> drivers/net/ethernet/wiznet/w5100-spi.c | 21 ++-----
> drivers/net/ethernet/wiznet/w5100.c | 61 ++++++++++---------
> drivers/net/ethernet/wiznet/w5100.h | 3 +-
> drivers/net/ethernet/wiznet/w5300.c | 54 ++++++++--------
> include/linux/platform_data/wiznet.h | 23 -------
> 6 files changed, 71 insertions(+), 95 deletions(-)
> delete mode 100644 include/linux/platform_data/wiznet.h