Re: [PATCH v4 2/2] selftests: KVM: Add dirty logging page splitting test

From: Ben Gardon
Date: Thu Jan 26 2023 - 17:52:19 EST


On Thu, Jan 26, 2023 at 12:06 PM Vipin Sharma <vipinsh@xxxxxxxxxx> wrote:
>
> On Wed, Jan 25, 2023 at 10:23 AM Ben Gardon <bgardon@xxxxxxxxxx> wrote:
>
> > +static void run_vcpus_get_page_stats(struct kvm_vm *vm, struct kvm_page_stats *stats, const char *stage)
> > +{
> > + int i;
> > +
> > + iteration++;
> > + for (i = 0; i < VCPUS; i++) {
> > + while (READ_ONCE(vcpu_last_completed_iteration[i]) !=
> > + iteration)
> > + ;
> > + }
> > +
> > + get_page_stats(vm, stats, stage);
>
> get_page_stats() is already called in run_test() explicitly for other
> stats. I think it's better to split this function and make the flow
> like:
>
> run_vcpus_till_iteration(iteration++);
> get_page_stats(vm, &stats_populated, "populating memory");
>
> This makes it easy to follow run_test_till_iteration() and easy to see
> where stats are collected. run_test_till_iteration() can also be a
> library function used by other tests like dirty_log_perf_test

Yeah, either way works. We can do it all in the run_tests function as
I originally had or we can have the run vcpus and get stats in a
helper as David suggested or we can separate run_vcpus and get_stats
helpers as you're suggesting. I don't think it makes much of a
difference.
If you feel strongly I can send out another iteration of this test.

>
>
> > + dirty_log_manual_caps = 0;
> > + for_each_guest_mode(run_test, NULL);
> > +
> > + dirty_log_manual_caps =
> > + kvm_check_cap(KVM_CAP_MANUAL_DIRTY_LOG_PROTECT2);
> > +
> > + if (dirty_log_manual_caps) {
> > + dirty_log_manual_caps &= (KVM_DIRTY_LOG_MANUAL_PROTECT_ENABLE |
> > + KVM_DIRTY_LOG_INITIALLY_SET);
> > + for_each_guest_mode(run_test, NULL);
> > + }
>
> Should there be a message to show that this capability is not tested
> as it is not available?
> Or, there can be a command line option to explicitly provide intent of
> testing combined, split modes, or both? Then test can error out
> accordingly.

Sure, that would work too. If I send another version of this series I
can add a skip message, but I don't want to re-add an option to
specify whether to run with MANUAL_PROTECT, because that's what I had
originally and then David suggested I remove it and just always run
both.