Re: [PATCH v4 5/6] arm64: dts: qcom: Add Square apq8039-t2 board

From: Konrad Dybcio
Date: Tue Jan 24 2023 - 20:30:06 EST




On 25.01.2023 02:21, Bryan O'Donoghue wrote:
> On 23/01/2023 16:29, Krzysztof Kozlowski wrote:
>> On 23/01/2023 03:31, Bryan O'Donoghue wrote:
>>> The apq8039-t2 is an apq8039 based board paired with a wcn3680b WiFi
>>> chipset.
>>>
>>> Co-developed-by: Shawn Guo <shawn.guo@xxxxxxxxxx>
>>> Signed-off-by: Shawn Guo <shawn.guo@xxxxxxxxxx>
>>> Co-developed-by: Jun Nie <jun.nie@xxxxxxxxxx>
>>> Signed-off-by: Jun Nie <jun.nie@xxxxxxxxxx>
>>> Co-developed-by: Benjamin Li <benl@xxxxxxxxxxxx>
>>> Signed-off-by: Benjamin Li <benl@xxxxxxxxxxxx>
>>> Co-developed-by: James Willcox <jwillcox@xxxxxxxxxxxx>
>>> Signed-off-by: James Willcox <jwillcox@xxxxxxxxxxxx>
>>> Co-developed-by: Leo Yan <leo.yan@xxxxxxxxxx>
>>> Signed-off-by: Leo Yan <leo.yan@xxxxxxxxxx>
>>> Co-developed-by: Joseph Gates <jgates@xxxxxxxxxxxx>
>>> Signed-off-by: Joseph Gates <jgates@xxxxxxxxxxxx>
>>> Co-developed-by: Max Chen <mchen@xxxxxxxxxxxx>
>>> Signed-off-by: Max Chen <mchen@xxxxxxxxxxxx>
>>> Co-developed-by: Zac Crosby <zac@xxxxxxxxxxxx>
>>> Signed-off-by: Zac Crosby <zac@xxxxxxxxxxxx>
>>> Signed-off-by: Bryan O'Donoghue <bryan.odonoghue@xxxxxxxxxx>
>>> ---
>>>   arch/arm64/boot/dts/qcom/Makefile       |   1 +
>>>   arch/arm64/boot/dts/qcom/apq8039-t2.dts | 545 ++++++++++++++++++++++++
>>>   2 files changed, 546 insertions(+)
>>>   create mode 100644 arch/arm64/boot/dts/qcom/apq8039-t2.dts
>>>
>>> diff --git a/arch/arm64/boot/dts/qcom/Makefile b/arch/arm64/boot/dts/qcom/Makefile
>>> index b0423ca3e79fd..73ff8d3213d99 100644
>>> --- a/arch/arm64/boot/dts/qcom/Makefile
>>> +++ b/arch/arm64/boot/dts/qcom/Makefile
>>> @@ -1,5 +1,6 @@
>>>   # SPDX-License-Identifier: GPL-2.0
>>>   dtb-$(CONFIG_ARCH_QCOM)    += apq8016-sbc.dtb
>>> +dtb-$(CONFIG_ARCH_QCOM)    += apq8039-t2.dtb
>>>   dtb-$(CONFIG_ARCH_QCOM)    += apq8094-sony-xperia-kitakami-karin_windy.dtb
>>>   dtb-$(CONFIG_ARCH_QCOM)    += apq8096-db820c.dtb
>>>   dtb-$(CONFIG_ARCH_QCOM)    += apq8096-ifc6640.dtb
>>> diff --git a/arch/arm64/boot/dts/qcom/apq8039-t2.dts b/arch/arm64/boot/dts/qcom/apq8039-t2.dts
>>> new file mode 100644
>>> index 0000000000000..734b4d6054132
>>> --- /dev/null
>>> +++ b/arch/arm64/boot/dts/qcom/apq8039-t2.dts
>>> @@ -0,0 +1,545 @@
>>> +// SPDX-License-Identifier: GPL-2.0
>>> +/*
>>> + * Copyright (c) 2015, The Linux Foundation. All rights reserved.
>>> + * Copyright (c) 2020-2023, Linaro Ltd.
>>> + *
>>> + */
>>> +
>>> +/dts-v1/;
>>> +
>>> +#include "msm8939.dtsi"
>>> +#include "msm8939-pm8916.dtsi"
>>> +#include <dt-bindings/arm/qcom,ids.h>
>>> +#include <dt-bindings/gpio/gpio.h>
>>> +#include <dt-bindings/pinctrl/qcom,pmic-gpio.h>
>>> +#include <dt-bindings/sound/apq8016-lpass.h>
>>> +
>>> +/ {
>>> +    model = "Square, Inc. T2 Devkit";
>>> +    compatible = "square,apq8039-t2", "qcom,msm8939";
>>
>> There is no square vendor prefix.
>
> commit d3e2262cd0d1105bb3a71012693876d01e8de203
> Author: Bryan O'Donoghue <bryan.odonoghue@xxxxxxxxxx>
> Date:   Tue Jan 17 02:48:39 2023 +0000
>
>     dt-bindings: arm: qcom: Document MSM8939 SoC binding
>
> +      - items:
> +          - enum:
> +              - sony,kanuti-tulip
> +              - square,apq8039-t2
> +          - const: qcom,msm8939
>
This is the board compatible. Krzysztof meant an entry for Square
in Documentation/devicetree/bindings/vendor-prefixes.yaml.

>
>>> +
>>> +    qcom,board-id = <0x53 0x54>;
>>> +    qcom,msm-id = <QCOM_ID_MSM8939 0>, <QCOM_ID_MSM8939 0x30000>, <QCOM_ID_APQ8039 0x30000>;
>>> +
>
>>> +
>>> +    lcd_avdd_reg: lcd-avdd-regulator {
>>
>> Since we try to have nodes ordered, how about naming them
>> "regulator-xxx", so whatever is added later will not spread them all over?
>
> Point taken.
>
> vreg_ looks like a more common prefix
>
> arch/arm64/boot/dts/qcom/sc8280xp-lenovo-thinkpad-x13s.dts: vreg_edp_3p3: regulator-edp-3p3 {
> vreg_edp_bl: regulator-edp-bl {
> vreg_misc_3p3: regulator-misc-3p3 {
> vreg_nvme: regulator-nvme {
> vreg_vph_pwr: regulator-vph-pwr {
> vreg_wlan: regulator-wlan {
> vreg_wwan: regulator-wwan {
>
>>> +    status = "okay";
>>> +
>>> +    typec: tps6598x@38 {
>>
>> Node names should be generic.
>> https://devicetree-specification.readthedocs.io/en/latest/chapter2-devicetree-basics.html#generic-names-recommendation
>
> None of those fit really
>
> typec_pd is upstream for the same IC, I'll reuse that.
Names, not labels.

label: name@unitaddress {

Konrad
>
> arch/arm64/boot/dts/freescale/imx8mq-librem5.dtsi
>
> ---
> bod