[PATCH v7 0/3] regulator: Add X-Powers AXP313a PMIC support*

From: Martin Botka
Date: Wed Jan 18 2023 - 16:03:46 EST


This patch series adds support for the X-Powers AXP313a PMIC, which is
often bundled with Allwinner H616 or H313 SoCs.
Andre Przywara took over the series for v6 but I now have a bit more time
so I took over the series again.

Up to v5 this was speaking of the AXP1530, which seems to be some internal
name. The chips we have seen in the wild are all labeled AXP313a, so we
go with this name here, from now on. This is supported by the fact that
there is an AXP313a datasheet, but none for the AXP1530.

Patch 1 is the binding documentation (just the new compatible string),
patch 2 adds the MFD bits (mostly describing the extent of the regmap),
while patch 3 describes the actual AXP313a register definitions.
Since this ties neatly into the existing AXP and generic regulator
framework, the patches are indeed only structure definitions, there is no
new code.

For now Andre papered over this "fixed customizable" RTC-LDO regulator in the
same way this was done before for other PMICs (AXP803, for instance), Andre
thinks we can fix this properly with a follow-up patch, for all instances.

Please have a look!

Cheers,
Martin

Changelog:
v6 .. v7:
- Use alphabetical ordering

v5 .. v6:
- change name from AXP1530 to AXP313a
- extend commit messages
- drop AXP*_FREQUENCY register (not used anyway)
- better vertically align struct definitions
- rename IRQs to match names used for other PMICs
- add RTC_LDO regulator
- use decimal numbers for selector ranges
- use macro definitions to name some values
- force DC/DC switching frequency to be fixed at 3 MHz
- change LDO source supply to VIN1 (as per datasheet)

v4 .. v5:
- Use alphabetical ordering in mfd
- Correct { placement line
- Replace spaces with tabs in 1 struct

v3 .. v4:
- Fix indentation

v2 .. v3:
- Move AXP1530 dt-binding to alphabetical order

v1 .. v2:
- Remove RSB support.
- Drop .id = 0
- Add dt-binding for the AXP1530

Martin Botka (3):
dt-bindings: mfd: x-powers,axp152: Document the AXP313a variant
mfd: axp20x: Add support for AXP313a PMIC
regulator: axp20x: Add support for AXP313a variant

.../bindings/mfd/x-powers,axp152.yaml | 1 +
drivers/mfd/axp20x-i2c.c | 2 +
drivers/mfd/axp20x.c | 61 +++++++++++++++++++
drivers/regulator/axp20x-regulator.c | 60 ++++++++++++++++++
include/linux/mfd/axp20x.h | 32 ++++++++++
5 files changed, 156 insertions(+)

--
2.39.0