Re: [PATCH v2 6/7] x86/power: Sprinkle some noinstr

From: Ingo Molnar
Date: Tue Jan 17 2023 - 04:33:02 EST



* Peter Zijlstra <peterz@xxxxxxxxxxxxx> wrote:

> + /*
> + * Definitely wrong, but at this point we should have at least enough
> + * to do CALL/RET (consider SKL callthunks) and this avoids having
> + * to deal with the noinstr explosion for now :/
> + */
> + instrumentation_begin();

BTW., readability side note: instrumentation_begin()/end() are the
misnomers of the century - they don't signal the start/end of instrumented
code areas like the name falsely & naively suggests, but the exact
opposite: start/end of *non-*instrumented code areas.

As such they should probably be something like:

noinstr_begin();
...
noinstr_end();

... to reuse the nomenclature of the 'noinstr' attribute?

Thanks,

Ingo