[PATCH] s390/vmem: use swap() instead of open coding it

From: Jiapeng Chong
Date: Tue Jan 17 2023 - 01:02:23 EST


Swap is a function interface that provides exchange function. To avoid
code duplication, we can use swap function.

./arch/s390/mm/vmem.c:680:10-11: WARNING opportunity for swap().

[hca@xxxxxxxxxxxxx: get rid of all temp variables]
Link: https://bugzilla.openanolis.cn/show_bug.cgi?id=3786
Reported-by: Abaci Robot <abaci@xxxxxxxxxxxxxxxxx>
Signed-off-by: Jiapeng Chong <jiapeng.chong@xxxxxxxxxxxxxxxxx>
Link: https://lore.kernel.org/r/20230117060223.58583-1-jiapeng.chong@xxxxxxxxxxxxxxxxx
Signed-off-by: Heiko Carstens <hca@xxxxxxxxxxxxx>
---
arch/s390/mm/vmem.c | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)

diff --git a/arch/s390/mm/vmem.c b/arch/s390/mm/vmem.c
index 78d7768f93d7..15daf777cf41 100644
--- a/arch/s390/mm/vmem.c
+++ b/arch/s390/mm/vmem.c
@@ -672,13 +672,7 @@ static int __init memblock_region_cmp(const void *a, const void *b)

static void __init memblock_region_swap(void *a, void *b, int size)
{
- struct memblock_region *r1 = a;
- struct memblock_region *r2 = b;
- struct memblock_region swap;
-
- swap = *r1;
- *r1 = *r2;
- *r2 = swap;
+ swap(*(struct memblock_region *)a, *(struct memblock_region *)b);
}

/*
--
2.34.1