Re: [PATCH v2 net-next 04/12] net: ethtool: netlink: retrieve stats from multiple sources (eMAC, pMAC)

From: Vladimir Oltean
Date: Sat Jan 14 2023 - 18:22:48 EST


On Fri, Jan 13, 2023 at 08:43:36PM -0800, Jakub Kicinski wrote:
> On Wed, 11 Jan 2023 18:16:58 +0200 Vladimir Oltean wrote:
> > +/**
> > + * enum ethtool_stats_src - source of ethtool statistics
> > + * @ETHTOOL_STATS_SRC_AGGREGATE:
> > + * if device supports a MAC merge layer, this retrieves the aggregate
> > + * statistics of the eMAC and pMAC. Otherwise, it retrieves just the
> > + * statistics of the single (express) MAC.
> > + * @ETHTOOL_STATS_SRC_EMAC:
> > + * if device supports a MM layer, this retrieves the eMAC statistics.
> > + * Otherwise, it retrieves the statistics of the single (express) MAC.
> > + * @ETHTOOL_STATS_SRC_PMAC:
> > + * if device supports a MM layer, this retrieves the pMAC statistics.
> > + */
> > +enum ethtool_stats_src {
> > + ETHTOOL_STATS_SRC_AGGREGATE,
> > + ETHTOOL_STATS_SRC_EMAC,
> > + ETHTOOL_STATS_SRC_PMAC,
> > +};
>
> Should we somehow call it "MAC stats"?
>
> Right now its named like a generic attribute, but it's not part of
> the header nest (ETHTOOL_A_HEADER_*).
>
> I'm not sure myself which way is better, but feels like either it
> should be generic, in the header nest, and parsed by the common code;
> or named more specifically and stay in the per-cmd attrs.

Considering that I currently have separate netlink attributes for
ETHTOOL_MSG_STATS_GET (ETHTOOL_A_STATS_SRC) and for
ETHTOOL_MSG_PAUSE_GET (ETHTOOL_A_PAUSE_STATS_SRC), I'm going to add just
a single attribute right under ETHTOOL_A_HEADER_FLAGS for v3 and go from
there. Is it ok if I keep naming it ETHTOOL_A_STATS_SRC, or would you
prefer something else?