Re: [PATCH v1 04/20] ARM: imx6q: use of_clk_get_by_name() instead of_clk_get() to get ptp clock

From: Stephen Boyd
Date: Fri Jan 13 2023 - 19:20:47 EST


Quoting Oleksij Rempel (2023-01-13 06:27:02)
> It is not clear from the code what clock should be taken. So, make sure it
> is readable and no other clock will be taken by accident.
>
> Signed-off-by: Oleksij Rempel <o.rempel@xxxxxxxxxxxxxx>
> ---
> arch/arm/mach-imx/mach-imx6q.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/arm/mach-imx/mach-imx6q.c b/arch/arm/mach-imx/mach-imx6q.c
> index 7f6200925752..4885d3dfcf7f 100644
> --- a/arch/arm/mach-imx/mach-imx6q.c
> +++ b/arch/arm/mach-imx/mach-imx6q.c
> @@ -98,7 +98,7 @@ static void __init imx6q_1588_init(void)
> if (!IS_ERR(fec_enet_ref))
> goto put_node;
>
> - ptp_clk = of_clk_get(np, 2);
> + ptp_clk = of_clk_get_by_name(np, "ptp");

The 'clocks' property in DTS should not be reordered. Order matters in
the binding. This patch makes the code do a string comparison (or a
few?) in the name of readability. Perhaps make a #define for '2' like
CLOCKS_PTP_INDEX, or just don't change it because it ain't broke.