Re: [PATCH v6 2/5] pwm: Add Apple PWM controller

From: Uwe Kleine-König
Date: Tue Jan 10 2023 - 18:07:31 EST


Hello Sasha,

On Fri, Jan 06, 2023 at 04:58:39PM +0300, Sasha Finkelstein wrote:
> Adds the Apple PWM controller driver.
>
> Signed-off-by: Sasha Finkelstein <fnkl.kernel@xxxxxxxxx>
> Acked-by: Sven Peter <sven@xxxxxxxxxxxxx>
> ---
> drivers/pwm/Kconfig | 12 ++++
> drivers/pwm/Makefile | 1 +
> drivers/pwm/pwm-apple.c | 156 ++++++++++++++++++++++++++++++++++++++++
> 3 files changed, 169 insertions(+)
> create mode 100644 drivers/pwm/pwm-apple.c
>
> diff --git a/drivers/pwm/Kconfig b/drivers/pwm/Kconfig
> index dae023d783a2..8df861b1f4a3 100644
> --- a/drivers/pwm/Kconfig
> +++ b/drivers/pwm/Kconfig
> @@ -51,6 +51,18 @@ config PWM_AB8500
> To compile this driver as a module, choose M here: the module
> will be called pwm-ab8500.
>
> +config PWM_APPLE
> + tristate "Apple SoC PWM support"
> + depends on ARCH_APPLE || COMPILE_TEST
> + help
> + Generic PWM framework driver for PWM controller present on
> + Apple SoCs
> +
> + Say Y here if you have an ARM Apple laptop, otherwise say N
> +
> + To compile this driver as a module, choose M here: the module
> + will be called pwm-apple.
> +
> config PWM_ATMEL
> tristate "Atmel PWM support"
> depends on ARCH_AT91 || COMPILE_TEST
> diff --git a/drivers/pwm/Makefile b/drivers/pwm/Makefile
> index 7bf1a29f02b8..19899b912e00 100644
> --- a/drivers/pwm/Makefile
> +++ b/drivers/pwm/Makefile
> @@ -2,6 +2,7 @@
> obj-$(CONFIG_PWM) += core.o
> obj-$(CONFIG_PWM_SYSFS) += sysfs.o
> obj-$(CONFIG_PWM_AB8500) += pwm-ab8500.o
> +obj-$(CONFIG_PWM_APPLE) += pwm-apple.o
> obj-$(CONFIG_PWM_ATMEL) += pwm-atmel.o
> obj-$(CONFIG_PWM_ATMEL_HLCDC_PWM) += pwm-atmel-hlcdc.o
> obj-$(CONFIG_PWM_ATMEL_TCB) += pwm-atmel-tcb.o
> diff --git a/drivers/pwm/pwm-apple.c b/drivers/pwm/pwm-apple.c
> new file mode 100644
> index 000000000000..5360583a5fa6
> --- /dev/null
> +++ b/drivers/pwm/pwm-apple.c
> @@ -0,0 +1,156 @@
> +// SPDX-License-Identifier: GPL-2.0 OR MIT
> +/*
> + * Driver for the Apple SoC PWM controller
> + *
> + * Copyright The Asahi Linux Contributors
> + *
> + * Limitations:
> + * - The writes to cycle registers are shadowed until a write to
> + * the control register.
> + * - If both OFF_CYCLES and ON_CYCLES are set to 0, the output
> + * is a constant off signal.

How does the PWM behave with *APPLE_PWM_CTRLAPPLE_PWM_CTRL = 0?
(typically: drives constant low)

> + */
> +
> +#include <linux/module.h>
> +#include <linux/platform_device.h>
> +#include <linux/pwm.h>
> +#include <linux/io.h>
> +#include <linux/clk.h>
> +#include <linux/math64.h>
> +
> +#define APPLE_PWM_CTRL 0x00
> +#define APPLE_PWM_ON_CYCLES 0x1c
> +#define APPLE_PWM_OFF_CYCLES 0x18
> +
> +#define APPLE_CTRL_ENABLE BIT(0)
> +#define APPLE_CTRL_MODE BIT(2)
> +#define APPLE_CTRL_UPDATE BIT(5)
> +#define APPLE_CTRL_TRIGGER BIT(9)
> +#define APPLE_CTRL_INVERT BIT(10)
> +#define APPLE_CTRL_OUTPUT_ENABLE BIT(14)

In reply to v4 I wrote:

| Would be nice if the register prefix would match the register name. That
| is please either rename APPLE_PWM_CONTROL to APPLE_PWM_CTRL or use
| APPLE_PWM_CONTROL as prefix for the bit fields in that register.

well, one of the two options was bogus because it doesn't result in the
intended effect. You picked that broken option :-\
Can you please rename such that the (maybe new) name for APPLE_PWM_CTRL
is a prefix for the (maybe new) APPLE_CTRL_ENABLE and the other register
bit definitions?

> [...]
> +static int apple_pwm_probe(struct platform_device *pdev)
> +{
> + struct apple_pwm *fpwm;
> + struct clk *clk;
> + int ret;
> +
> + fpwm = devm_kzalloc(&pdev->dev, sizeof(*fpwm), GFP_KERNEL);
> + if (!fpwm)
> + return -ENOMEM;
> +
> + fpwm->base = devm_platform_ioremap_resource(pdev, 0);
> + if (IS_ERR(fpwm->base))
> + return dev_err_probe(&pdev->dev, PTR_ERR(fpwm->base), "unable to map mmio");

devm_platform_ioremap_resource() already emits an error message if there
is a problem. So please don't add another message here.

> + clk = devm_clk_get_enabled(&pdev->dev, NULL);
> + if (IS_ERR(clk))
> + return dev_err_probe(&pdev->dev, PTR_ERR(clk), "unable to get the clock");
> +
> + /*
> + * uses the 24MHz system clock on all existing devices, can only
> + * happen if the device tree is broken
> + */
> + fpwm->clkrate = clk_get_rate(clk);
> + if (fpwm->clkrate > NSEC_PER_SEC)
> + return dev_err_probe(&pdev->dev, -EINVAL, "pwm clock out of range");

This check is done to prevent an overflow in .apply, right? Please point
that out in a comment.

> + fpwm->chip.dev = &pdev->dev;
> + fpwm->chip.npwm = 1;
> + fpwm->chip.ops = &apple_pwm_ops;
> +
> + ret = devm_pwmchip_add(&pdev->dev, &fpwm->chip);
> + if (ret < 0)
> + return dev_err_probe(&pdev->dev, ret, "unable to add pwm chip");
> +
> + return 0;
> +}
> +
> [...]

Best regards
Uwe

--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | https://www.pengutronix.de/ |

Attachment: signature.asc
Description: PGP signature