RE: [PATCH v4 4/4] rcu: Add RCU stall diagnosis information

From: Elliott, Robert (Servers)
Date: Fri Nov 04 2022 - 21:59:33 EST



> --- a/kernel/rcu/Kconfig.debug
> +++ b/kernel/rcu/Kconfig.debug
> @@ -95,6 +95,16 @@ config RCU_EXP_CPU_STALL_TIMEOUT
> says to use the RCU_CPU_STALL_TIMEOUT value converted from
> seconds to milliseconds.
>
> +config RCU_CPU_STALL_CPUTIME

Since the information might change and grow over time, consider
calling it "ADDITIONAL_INFO" rather than just "CPUTIME".

> + bool "Provide additional rcu stall debug information"
> + depends on RCU_STALL_COMMON
> + default n
> + help
> + Statistics during the period from RCU_CPU_STALL_TIMEOUT/2 to
> + RCU_CPU_STALL_TIMEOUT, such as the number of (hard interrupts,
> soft
> + interrupts, task switches) and the cputime of (hard interrupts,
> soft
> + interrupts, kerenl tasks) are added to the rcu stall report.

s/kerenl/kernel/

Those parenthetical words are not grammatically correct, and
nobody will remember to update Kconfig if they change the code.

Try making it is a little less precise:
"Collect statistics during the RCU stall timeout period
(e.g., counts and CPU time consumed by hard interrupts, soft
interrupts, task switches, and kernel tasks) and include
them in the RCU stall console error message."

...
> +
> + pr_err(" hardirqs softirqs csw/system\n");
> + pr_err(" number: %8ld %10d %12lld\n",

Everything after a %d is a "number". These are more specifically counts.

> + kstat_cpu_irqs_sum(cpu) - rsrp->nr_hardirqs,
> + kstat_cpu_softirqs_sum(cpu) - rsrp->nr_softirqs,
> + nr_context_switches_cpu(cpu) - rsrp->nr_csw);

Two columns are plural and one is not.

Within a few lines, this is referred to as "context_switches", cws,
and "task switches." One term would be better. vmstat uses "cs",
pidstat uses "cswch", and /proc/<pid>/status uses "ctxt_switches,"
so there's not one ideal term for that column. Matching one
of those might be better than using another unique name.

Since no other variants are shown, the "/system" suffix is a bit
confusing.


> + pr_err("cputime: %8lld %10lld %12lld ==> %lld(ms)\n",
> + div_u64(cpustat[CPUTIME_IRQ] - rsrp->cputime_irq, NSEC_PER_MSEC),
> + div_u64(cpustat[CPUTIME_SOFTIRQ] - rsrp->cputime_softirq, NSEC_PER_MSEC),
> + div_u64(cpustat[CPUTIME_SYSTEM] - rsrp->cputime_system, NSEC_PER_MSEC),
> + jiffies64_to_msecs(half_timeout));

There is no column header for that fourth number. "half_timeout"
might be good, dropping the "==>".

The "(ms)" at the end is awkward. Try moving it to the left
as "cputime (ms): "

> +int rcu_cpu_stall_cputime __read_mostly =
> IS_ENABLED(CONFIG_RCU_CPU_STALL_CPUTIME);

As a config option and module parameter, adding some more
instrumentation overhead might be worthwhile for other
likely causes of rcu stalls.

For example, if enabled, have these functions (if available
on the architecture) maintain a per-CPU running count of
their invocations, which also cause the CPU to be unavailable
for rcu:
- kernel_fpu_begin() calls - FPU/SIMD context preservation,
which also calls preempt_disable()
- preempt_disable() calls - scheduler context switches disabled
- local_irq_save() calls - interrupts disabled
- cond_resched() calls - lack of these is a problem

For kernel_fpu_begin and preempt_disable, knowing if it is
currently blocked for those reasons is probably the most
helpful.