Re: [PATCH 16/16] phy: qcom-qmp-usb: shorten function prefixes

From: Johan Hovold
Date: Fri Sep 09 2022 - 09:27:50 EST


On Fri, Sep 09, 2022 at 12:48:48PM +0300, Dmitry Baryshkov wrote:
> On 07/09/2022 14:07, Johan Hovold wrote:
> > The driver function prefix has gotten unnecessarily long and hurts
> > readability.
> >
> > Shorten "qcom_qmp_phy_" to "qmp_" (which likely stands for "Qualcomm
> > Multi PHY" or similar anyway).
> >
> > Signed-off-by: Johan Hovold <johan+linaro@xxxxxxxxxx>
> > ---
> > drivers/phy/qualcomm/phy-qcom-qmp-ufs.c | 3 +-
> > drivers/phy/qualcomm/phy-qcom-qmp-usb.c | 121 ++++++++++++------------
> > 2 files changed, 60 insertions(+), 64 deletions(-)
> >
> > diff --git a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> > index b020409b92e0..4d0eee620f37 100644
> > --- a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> > +++ b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> > @@ -1105,8 +1105,7 @@ static const struct phy_ops qcom_qmp_ufs_ops = {
> > .owner = THIS_MODULE,
> > };
> >
> > -static
> > -int qmp_ufs_create(struct device *dev, struct device_node *np, int id,
> > +static int qmp_ufs_create(struct device *dev, struct device_node *np, int id,
> > void __iomem *serdes, const struct qmp_phy_cfg *cfg)
>
> This likely should go to the previous patch.

Ah, must have amended the wrong commit. Thanks for catching that.

Not sure its worth resending the series for though.

Vinod, could you fix it up or do you prefer I respin?

> Otherwise:
>
> Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx>

Johan