[PATCH v6 0/2] x86/asm/bitops: optimize ff{s,z} functions for constant expressions

From: Vincent Mailhol
Date: Wed Aug 31 2022 - 03:58:26 EST


The compilers provide some builtin expression equivalent to the ffs(),
__ffs() and ffz() functions of the kernel. The kernel uses optimized
assembly which produces better code than the builtin
functions. However, such assembly code can not be folded when used
with constant expressions.

This series relies on __builtin_constant_p to select the optimal solution:

* use kernel assembly for non constant expressions

* use compiler's __builtin function for constant expressions.


** Statistics **

Patch 1/2 optimizes 26.7% of ffs() calls and patch 2/2 optimizes 27.9%
of __ffs() and ffz() calls (details of the calculation in each patch).


** Changelog **

v5 -> v6:
* Rename variable___ffs() into variable__ffs() (two underscores
instead of three)


v4 -> v5:

* (no changes on code, only commit comment was modified)

* Rewrite the commit log:
- Use two spaces instead of `| ' to indent code snippets.
- Do not use `we'.
- Do not use `this patch' in the commit description. Instead,
use imperative tone.
Link: https://lore.kernel.org/all/YvUZVYxbOMcZtR5G@xxxxxxx/


v3 -> v4:

* (no changes on code, only commit comment was modified)

* Remove note and link to Nick's message in patch 1/2, c.f.:
Link: https://lore.kernel.org/all/CAKwvOdnnDaiJcV1gr9vV+ya-jWxx7+2KJNTDThyFctVDOgt9zQ@xxxxxxxxxxxxxx/

* Add Reviewed-by: Nick Desaulniers <ndesaulniers@xxxxxxxxxx> tag in
patch 2/2.


v2 -> v3:

* Redacted out the instructions after ret and before next function
in the assembly output.

* Added a note and a link to Nick's message on the constant
propagation missed-optimization in clang:
Link: https://lore.kernel.org/all/CAKwvOdnH_gYv4qRN9pKY7jNTQK95xNeH1w1KZJJmvCkh8xJLBg@xxxxxxxxxxxxxx/

* Fix copy/paste typo in statistics of patch 1/2. Number of
occurences before patches are 1081 and not 3607 (percentage
reduction of 26.7% remains correct)

* Rename the functions as follow:
- __varible_ffs() -> variable___ffs()
- __variable_ffz() -> variable_ffz()

* Add Reviewed-by: Nick Desaulniers <ndesaulniers@xxxxxxxxxx> tag in
patch 1/2.

Vincent Mailhol (2):
x86/asm/bitops: ffs: use __builtin_ffs to evaluate constant
expressions
x86/asm/bitops: __ffs,ffz: use __builtin_ctzl to evaluate constant
expressions

arch/x86/include/asm/bitops.h | 64 +++++++++++++++++++++--------------
1 file changed, 38 insertions(+), 26 deletions(-)

--
2.35.1