Re: [PATCH v4 3/3] KVM: x86: Print guest pgd in kvm_nested_vmenter()

From: Sean Christopherson
Date: Tue Aug 30 2022 - 17:30:02 EST


On Thu, Aug 25, 2022, Mingwei Zhang wrote:
> ---
> diff --git a/arch/x86/kvm/trace.h b/arch/x86/kvm/trace.h
> index e7f0da9474f0..b2be0348bb14 100644
> --- a/arch/x86/kvm/trace.h
> +++ b/arch/x86/kvm/trace.h
> @@ -591,9 +591,10 @@ TRACE_EVENT(kvm_pv_eoi,
> */
> TRACE_EVENT(kvm_nested_vmenter,
> TP_PROTO(__u64 rip, __u64 vmcb, __u64 nested_rip, __u32 int_ctl,
> - __u32 event_inj, bool tdp_enabled, __u32 isa),
> + __u32 event_inj, bool tdp_enabled, __u64 guest_tdp,

s/guest_tdp_pgd to differentiate it from "tdp_enabled"


> TP_printk("rip: 0x%016llx %s: 0x%016llx nested_rip: 0x%016llx "
> - "int_ctl: 0x%08x event_inj: 0x%08x nested_%s: %s",
> + "int_ctl: 0x%08x event_inj: 0x%08x nested_%s: %s, "
> + "guest_pgd: 0x%016llx",

It's a little gross, but this can spit out nested_eptp vs. nested_cr3 vs. guest_cr3.

> __entry->rip,
> __entry->isa == KVM_ISA_VMX ? "vmcs" : "vmcb",
> __entry->vmcb,

> @@ -624,7 +628,8 @@ TRACE_EVENT(kvm_nested_vmenter,
> __entry->int_ctl,
> __entry->event_inj,
> __entry->isa == KVM_ISA_VMX ? "ept" : "npt",
> - __entry->tdp_enabled ? "on" : "off")
> + __entry->tdp_enabled ? "on" : "off",

To keep things aligned, and because "on nested_eptp" reads as a combined
snippet

event_inj: 0x00000000 nested_ept: off guest_cr3: 0x0000000001007000
event_inj: 0x00000000 nested_ept: off guest_cr3: 0x0000000001007000
event_inj: 0x00000000 nested_ept: on nested_eptp: 0x0000000007ec501e
event_inj: 0x00000000 nested_ept: on nested_eptp: 0x0000000007ec501e

what about teaking the format so that the output looks like this?

event_inj: 0x00000000 nested_ept=n guest_cr3: 0x0000000001007000
event_inj: 0x00000000 nested_ept=n guest_cr3: 0x0000000001007000
event_inj: 0x00000000 nested_ept=y nested_eptp: 0x0000000007ec501e
event_inj: 0x00000000 nested_ept=y nested_eptp: 0x0000000007ec501e

Deviating from the ": " style bothers me, but I find this difficult to read.
Again, letters delimited by whitespace get visually clumped together.

event_inj: 0x00000000 nested_ept: n guest_cr3: 0x0000000001007000
event_inj: 0x00000000 nested_ept: n guest_cr3: 0x0000000001007000
event_inj: 0x00000000 nested_ept: y nested_eptp: 0x0000000007ec501e
event_inj: 0x00000000 nested_ept: y nested_eptp: 0x0000000007ec501e

And this looks like a typo

event_inj: 0x00000000 nested_ept:n guest_cr3: 0x0000000001007000
event_inj: 0x00000000 nested_ept:n guest_cr3: 0x0000000001007000
event_inj: 0x00000000 nested_ept:y nested_eptp: 0x0000000007ec501e
event_inj: 0x00000000 nested_ept:y nested_eptp: 0x0000000007ec501e

We could leave off the nested_{ept/npt} entirely and leave the differentation to
the nested_eptp vs. nested_cr3 vs. guest_cr3, but I don't think that's worth
shaving a few chars.