Re: [PATCH] misc: fastrpc: Use USER_PD define in fastrpc_get_info_from_dsp

From: Srinivas Kandagatla
Date: Wed Aug 17 2022 - 07:09:06 EST




On 16/08/2022 11:55, Abel Vesa wrote:
There are defines for each type of protection domain now.
Use the USER_PD instead of magic value in fastrpc_get_info_from_dsp.

Signed-off-by: Abel Vesa <abel.vesa@xxxxxxxxxx>
Cc: Srinivas Kandagatla <srinivas.kandagatla@xxxxxxxxxx>
Cc: Amol Maheshwari <amahesh@xxxxxxxxxxxxxxxx>
---

LGTM

Reviewed-by: Srinivas Kandagatla <srinivas.kandagatla@xxxxxxxxxx>


--srini
drivers/misc/fastrpc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/misc/fastrpc.c b/drivers/misc/fastrpc.c
index 93ebd174d848..8895ca593911 100644
--- a/drivers/misc/fastrpc.c
+++ b/drivers/misc/fastrpc.c
@@ -1515,7 +1515,7 @@ static int fastrpc_get_info_from_dsp(struct fastrpc_user *fl, uint32_t *dsp_attr
args[1].ptr = (u64)(uintptr_t)&dsp_attr_buf[1];
args[1].length = dsp_attr_buf_len;
args[1].fd = -1;
- fl->pd = 1;
+ fl->pd = USER_PD;
return fastrpc_internal_invoke(fl, true, FASTRPC_DSP_UTILITIES_HANDLE,
FASTRPC_SCALARS(0, 1, 1), args);