[PATCH] Bluetooth: hci_core: Use ERR_PTR instead of NULL

From: Khalid Masum
Date: Sun Jul 17 2022 - 09:38:22 EST


Failure of kzalloc to allocate memory is not reported. Return Error
pointer to ENOMEM if memory allocation fails. This will increase
readability and will make the function easier to use in future.

Signed-off-by: Khalid Masum <khalid.masum.92@xxxxxxxxx>
---
drivers/bluetooth/btusb.c | 4 ++--
net/bluetooth/hci_core.c | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
index e25fcd49db70..3407762b3b15 100644
--- a/drivers/bluetooth/btusb.c
+++ b/drivers/bluetooth/btusb.c
@@ -3692,8 +3692,8 @@ static int btusb_probe(struct usb_interface *intf,
data->recv_acl = hci_recv_frame;

hdev = hci_alloc_dev_priv(priv_size);
- if (!hdev)
- return -ENOMEM;
+ if (IS_ERR(hdev))
+ return PTR_ERR(hdev);

hdev->bus = HCI_USB;
hci_set_drvdata(hdev, data);
diff --git a/net/bluetooth/hci_core.c b/net/bluetooth/hci_core.c
index a0f99baafd35..ea50767e02bf 100644
--- a/net/bluetooth/hci_core.c
+++ b/net/bluetooth/hci_core.c
@@ -2419,7 +2419,7 @@ struct hci_dev *hci_alloc_dev_priv(int sizeof_priv)

hdev = kzalloc(alloc_size, GFP_KERNEL);
if (!hdev)
- return NULL;
+ return ERR_PTR(-ENOMEM);

hdev->pkt_type = (HCI_DM1 | HCI_DH1 | HCI_HV1);
hdev->esco_type = (ESCO_HV1);
--
2.36.1