Re: [PATCH v5 07/15] dt-bindings: reset: amd,pensando-elbasr-reset: Add AMD Pensando SR Reset Controller bindings

From: Brad Larson
Date: Sun Jul 03 2022 - 19:34:36 EST


Hi Rob,

On Tue, Jun 14, 2022 at 2:32 PM Rob Herring <robh@xxxxxxxxxx> wrote:
>
> On Mon, Jun 13, 2022 at 12:56:50PM -0700, Brad Larson wrote:
> > From: Brad Larson <blarson@xxxxxxx>
> >
> > Document bindings for AMD Pensando Elba SR Reset Controller
> >
> > Signed-off-by: Brad Larson <blarson@xxxxxxx>
> > ---
> > .../reset/amd,pensando-elbasr-reset.yaml | 62 +++++++++++++++++++
> > 1 file changed, 62 insertions(+)
> > create mode 100644 Documentation/devicetree/bindings/reset/amd,pensando-elbasr-reset.yaml
> >
> > diff --git a/Documentation/devicetree/bindings/reset/amd,pensando-elbasr-reset.yaml b/Documentation/devicetree/bindings/reset/amd,pensando-elbasr-reset.yaml
> > new file mode 100644
> > index 000000000000..03bb86ebcfd3
> > --- /dev/null
> > +++ b/Documentation/devicetree/bindings/reset/amd,pensando-elbasr-reset.yaml
> > @@ -0,0 +1,62 @@
> > +# SPDX-License-Identifier: (GPL-2.0 OR BSD-2-Clause)
> > +%YAML 1.2
> > +---
> > +$id: http://devicetree.org/schemas/reset/amd,pensando-elbasr-reset.yaml#
> > +$schema: http://devicetree.org/meta-schemas/core.yaml#
> > +
> > +title: AMD Pensando Elba SoC Reset Controller Device Tree Bindings
> > +
> > +maintainers:
> > + - Brad Larson <blarson@xxxxxxx>
> > +
> > +description: |
> > + AMD Pensando Elba SoC reset controller driver which supports a resource
> > + controller connected to the Elba SoC over a SPI bus. The Elba reset
> > + controller must be defined as a child node of the Elba SPI bus
> > + chip-select 0 node.
> > +
> > + See also:
> > + - dt-bindings/reset/amd,pensando-elba-reset.h
> > +
> > +properties:
> > + $nodename:
> > + pattern: "^reset-controller@[0-9a-f]+$"
> > +
> > + compatible:
> > + const: amd,pensando-elbasr-reset
> > +
> > + reg:
> > + const: 0
> > +
> > + '#reset-cells':
> > + const: 1
> > +
> > +required:
> > + - compatible
> > + - reg
> > + - '#reset-cells'
> > +
> > +additionalProperties: false
> > +
> > +examples:
> > + - |
> > + #include <dt-bindings/reset/amd,pensando-elba-reset.h>
> > + spi0 {
> > + #address-cells = <1>;
> > + #size-cells = <0>;
> > + num-cs = <4>;
> > +
> > + spi@0 {
>
> 'spi' is reserved for SPI buses. I thought this was an MFD.

Looking at other drivers/mfd files the naming convention could allow
the following, how about this?

spi@0 {
sr_regs@0 {
rstc: reset-controller@0 {

dw_i2c@1 {

lattice_i2c@2 {

flash@3 {

Regards,
Brad