Re: [RFC PATCH v3 1/3] mm: Factor out the pagetable pages account into new helper function

From: Baolin Wang
Date: Sun Jul 03 2022 - 09:48:17 EST




On 7/2/2022 6:15 PM, Mike Rapoport wrote:
On Fri, Jul 01, 2022 at 04:00:59PM +0800, Baolin Wang wrote:


On 6/30/2022 10:11 PM, Mike Rapoport wrote:
On Thu, Jun 30, 2022 at 07:11:14PM +0800, Baolin Wang wrote:
Factor out the pagetable pages account into new helper functions to avoid
duplicated code. Meanwhile these helper functions also will be used to
account pagetable pages which do not need split pagetale lock.

Meanwhile convert to use mod_lruvec_page_state() in case of non-order-0
page table allocation.

These are *very* rare. I think only parisc may have non-order-0 pmd and pud
tables.

s390 also has non-order-0 page table allocation, but they both do not use
the generic page table allocation now.

With that, I'd suggest making use of compound_nr() build time opt-in.

After more thinking, I'd prefer to change back to use
inc_lruvec_page_state()/dec_lruvec_page_state(), since now no architecures
will need non-order-0 page table allocation.

After this patchset, I plan to convert parisc and s390 to use generic
pagetable allocation, then I will add non-order-0 page table allocation
support. Like Matthew suggested, maybe I need change the API to pass the
number of pages.

I think it would be simpler to add proper accounting to s390 and parisc
versions than make them use the generic allocation functions. Moreover, API
change to support these cases feels like unnecessary churn to me.

Got it. Thanks.