[PATCH 0/4] Introduce bitmap_size()

From: Christophe JAILLET
Date: Sat Jul 02 2022 - 14:29:07 EST


This serie introduces bitmap_size() which returns the size, in bytes, of a
bitmap. Such a function is useful to simplify some drivers that use vmalloc() or
other functions to allocate some butmaps.
It also hides some implementation details about how bitmaps are stored (array of
longs)

Before introducing this function in patch 3, patch 1 and 2 rename some functions
with the same name but with different meaning.

Finaly, patch 4 makes use of the new function in bitmap.h.


Other follow-up patches to simplify some drivers will be proposed later if/when
this serie is merged.

Christophe JAILLET (4):
s390/cio: Rename bitmap_size() as idset_bitmap_size()
fs/ntfs3: Rename bitmap_size() as ntfs3_bitmap_size()
bitmap: Introduce bitmap_size()
bitmap: Use bitmap_size()

drivers/md/dm-clone-metadata.c | 5 -----
drivers/s390/cio/idset.c | 8 ++++----
fs/ntfs3/bitmap.c | 4 ++--
fs/ntfs3/fsntfs.c | 2 +-
fs/ntfs3/index.c | 6 +++---
fs/ntfs3/ntfs_fs.h | 2 +-
fs/ntfs3/super.c | 2 +-
include/linux/bitmap.h | 15 +++++++++------
lib/math/prime_numbers.c | 2 --
9 files changed, 21 insertions(+), 25 deletions(-)

--
2.34.1