[PATCH v2 bpf-next 0/2] bpf: add a ksym BPF iterator

From: Alan Maguire
Date: Fri Jul 01 2022 - 05:28:27 EST


a ksym BPF iterator would be useful as it would allow more flexible
interactions with kernel symbols than are currently supported; it could
for example create more efficient map representations for lookup,
speed up symbol resolution etc.

The idea was initially discussed here [1].

Changes since RFC [2]:

- change name of iterator (and associated structures/fields) to "ksym"
(Andrii, patches 1, 2)
- remove dependency on CONFIG_PROC_FS; it was used for other BPF
iterators, and I assumed it was needed because of seq ops but I
don't think it is required on digging futher (Andrii, patch 1)

[1] https://lore.kernel.org/all/YjRPZj6Z8vuLeEZo@krava/
[2] https://lore.kernel.org/all/1656089118-577-1-git-send-email-alan.maguire@xxxxxxxxxx/


Alan Maguire (2):
bpf: add a ksym BPF iterator
selftests/bpf: add a ksym iter subtest

kernel/kallsyms.c | 89 +++++++++++++++++++++++
tools/testing/selftests/bpf/prog_tests/bpf_iter.c | 16 ++++
tools/testing/selftests/bpf/progs/bpf_iter_ksym.c | 71 ++++++++++++++++++
3 files changed, 176 insertions(+)
create mode 100644 tools/testing/selftests/bpf/progs/bpf_iter_ksym.c

--
1.8.3.1