Re: [PATCH] ceph:use DEFINE_DEBUGFS_ATTRIBUTE to define debugfs fops

From: Jeff Layton
Date: Tue May 31 2022 - 07:52:50 EST


On Tue, 2022-05-31 at 19:39 +0800, Tan Zhongjun wrote:
> It is more clear to use DEFINE_DEBUGFS_ATTRIBUTE to define
> debugfs file operation rather than DEFINE_SIMPLE_ATTRIBUTE.
>
> Signed-off-by: Tan Zhongjun
> ---
>  fs/ceph/debugfs.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fs/ceph/debugfs.c b/fs/ceph/debugfs.c
> index bec3c4549c07..05d15a0bbd9b 100644
> --- a/fs/ceph/debugfs.c
> +++ b/fs/ceph/debugfs.c
> @@ -386,7 +386,7 @@ static int congestion_kb_get(void *data, u64 *val)
>  return 0;
>  }
>  
> -DEFINE_SIMPLE_ATTRIBUTE(congestion_kb_fops, congestion_kb_get,
> +DEFINE_DEBUGFS_ATTRIBUTE(congestion_kb_fops, congestion_kb_get,
>  congestion_kb_set, "%llu\n");
>  
>  

You're now the 5th person to propose this patch.

Here are the first three postings. I'm too lazy to look up the 4th, but
it was just a few months ago.

https://lore.kernel.org/ceph-devel/1577111958-100981-1-git-send-email-chenwandun@xxxxxxxxxx/

https://lore.kernel.org/ceph-devel/1612165930-110076-1-git-send-email-jiapeng.chong@xxxxxxxxxxxxxxxxx/

https://lore.kernel.org/ceph-devel/20211221143614.480385-1-deng.changcheng@xxxxxxxxxx/

It's not as simple as doing a 1:1 conversion like this. Please look at
the threads above and offer a revised patch or let us know whether you
want us to drop this one.
--
Jeff Layton <jlayton@xxxxxxxxxx>