[PATCH] mm/daemon: describe NR_DAMON_OPS in damon_ops_id

From: Khalid Masum
Date: Mon May 23 2022 - 16:54:11 EST


NR_DAMON_OPS in the enum damon_ops_id is not described. Describe it for
better readability and also to fix a warning generated by make docs.

"NR" is described as "Total Number" and "DAMON_OPS" is described as
"Monitoring operations" in the same file. Hence describe NR_DAMON_OPS
as "Total number of damon operations".

Signed-off-by: Khalid Masum <khalid.masum.92@xxxxxxxxx>
---
include/linux/damon.h | 1 +
1 file changed, 1 insertion(+)

diff --git a/include/linux/damon.h b/include/linux/damon.h
index f23cbfa42..9e9fb4d78 100644
--- a/include/linux/damon.h
+++ b/include/linux/damon.h
@@ -262,6 +262,7 @@ struct damos {
*
* @DAMON_OPS_VADDR: Monitoring operations for virtual address spaces
* @DAMON_OPS_PADDR: Monitoring operations for the physical address space
+ * @NR_DAMON_OPS: Total number of monitoring operations
*/
enum damon_ops_id {
DAMON_OPS_VADDR,
--
2.25.1