Re: [PATCH 02/15] mm/swap: use helper macro __ATTR_RW

From: Oscar Salvador
Date: Wed May 18 2022 - 04:47:12 EST


On Mon, May 09, 2022 at 09:14:03PM +0800, Miaohe Lin wrote:
> Use helper macro __ATTR_RW to define vma_ra_enabled_attr to make code more
> clear. Minor readability improvement.
>
> Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx>

Reviewed-by: Oscar Salvador <osalvador@xxxxxxx>

> ---
> mm/swap_state.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/mm/swap_state.c b/mm/swap_state.c
> index 240b39ed5922..9f99d8137ffd 100644
> --- a/mm/swap_state.c
> +++ b/mm/swap_state.c
> @@ -881,9 +881,7 @@ static ssize_t vma_ra_enabled_store(struct kobject *kobj,
>
> return count;
> }
> -static struct kobj_attribute vma_ra_enabled_attr =
> - __ATTR(vma_ra_enabled, 0644, vma_ra_enabled_show,
> - vma_ra_enabled_store);
> +static struct kobj_attribute vma_ra_enabled_attr = __ATTR_RW(vma_ra_enabled);
>
> static struct attribute *swap_attrs[] = {
> &vma_ra_enabled_attr.attr,
> --
> 2.23.0
>
>

--
Oscar Salvador
SUSE Labs