Re: [PATCH 2/5] iommu: Add blocking_domain_ops field in iommu_ops

From: Jason Gunthorpe
Date: Mon May 16 2022 - 09:05:44 EST


On Mon, May 16, 2022 at 12:27:41AM -0700, Christoph Hellwig wrote:
> On Mon, May 16, 2022 at 09:57:56AM +0800, Lu Baolu wrote:
> > Each IOMMU driver must provide a blocking domain ops. If the hardware
> > supports detaching domain from device, setting blocking domain equals
> > detaching the existing domain from the deivce. Otherwise, an UNMANAGED
> > domain without any mapping will be used instead.
>
> blocking in this case means not allowing any access? The naming
> sounds a bit odd to me as blocking in the kernel has a specific
> meaning. Maybe something like noaccess ops might be a better name?

It is because of this:

include/linux/iommu.h: * IOMMU_DOMAIN_BLOCKED - All DMA is blocked, can be used to isolate
include/linux/iommu.h:#define IOMMU_DOMAIN_BLOCKED (0U)

noaccess might be clearer

Jason