Re: [PATCH 2/4] mm: ioremap: Add arch_ioremap/iounmap_check()

From: Christoph Hellwig
Date: Thu Apr 28 2022 - 11:46:15 EST


On Thu, Apr 28, 2022 at 02:16:39PM +0800, Kefeng Wang wrote:
> > Pet peeve. The word "check" is a poor one. I gives no sense of what
> > the function is checking and it gives no sense of how the function's
> > return value relates to the thing which it checks.
> >
> > Maybe it returns 0 on success and -EINVAL on failure. Don't know!
> >
> > Don't you think that better names would be io_remap_ok(),
> > io_remap_valid(), io_remap_allowed(), etc?
>
> Will use arch_ioremap/unmap_allowed(), and I'd like to keep return bool
>
> for now if there is no special requirements.

Actually, there are a few architectures that can successfully ioreamp
without setting up new ptes, e.g. mips.

So I think I'd name them just arch_ioremap and arch_iounmap, and
return a "void __іomem *" from arch_ioremap, where:

- IS_ERR means return an error
- NULL means continue to remap
- a non-NULL, non-IS_ERR pointer is directly returned.