Re: [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail()

From: Chao Yu
Date: Tue Apr 12 2022 - 06:55:46 EST


On 2022/4/1 6:16, Jakob Koschel wrote:
In preparation to limit the scope of a list iterator to the list
traversal loop, use a dedicated pointer to point to the found element
[1].

If no break is hit or the list is empty, 'next' will be NULL and
list_move_tail() should be called explicitly on the head directly.

Link: https://lore.kernel.org/all/CAHk-=wgRr_D8CB-D9Kg-c=EHreAsk5SqXPwr9Y7k9sA6cWXJ6w@xxxxxxxxxxxxxx/
Signed-off-by: Jakob Koschel <jakobkoschel@xxxxxxxxx>
---
fs/f2fs/segment.c | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

diff --git a/fs/f2fs/segment.c b/fs/f2fs/segment.c
index 22dfeb991529..81ef2c3d08e5 100644
--- a/fs/f2fs/segment.c
+++ b/fs/f2fs/segment.c
@@ -4175,16 +4175,20 @@ static void release_sit_entry_set(struct sit_entry_set *ses)
static void adjust_sit_entry_set(struct sit_entry_set *ses,
struct list_head *head)
{
- struct sit_entry_set *next = ses;
+ struct sit_entry_set *next = NULL, *iter = ses;
if (list_is_last(&ses->set_list, head))
return;
- list_for_each_entry_continue(next, head, set_list)
- if (ses->entry_cnt <= next->entry_cnt)
+ list_for_each_entry_continue(iter, head, set_list)
+ if (ses->entry_cnt <= iter->entry_cnt) {
+ next = iter;
+ list_move_tail(&ses->set_list, &iter->set_list);
break;

return;

+ }
- list_move_tail(&ses->set_list, &next->set_list);
+ if (!next)
+ list_move_tail(&ses->set_list, head);

list_move_tail(&ses->set_list, head);

Then we don't need @next variable, right?

Thanks,

}
static void add_sit_entry(unsigned int segno, struct list_head *head)

base-commit: d888c83fcec75194a8a48ccd283953bdba7b2550