Re: [PATCH v4 09/13] pinctrl: meson: Rename REG_* to MESON_REG_*

From: Geert Uytterhoeven
Date: Mon Apr 11 2022 - 05:04:25 EST


Hi Andy,

On Fri, Apr 1, 2022 at 12:36 PM Andy Shevchenko
<andriy.shevchenko@xxxxxxxxxxxxxxx> wrote:
> Currently compilation test fails on x86 due to name collision. The usual
> way to fix that is to move both conflicting parts to their own namespaces.
>
> Rename REG_* to MESON_REG_* as a prerequisite for enabling COMPILE_TEST.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>

Thanks for your patch!

> --- a/drivers/pinctrl/meson/pinctrl-meson.h
> +++ b/drivers/pinctrl/meson/pinctrl-meson.h
> @@ -63,12 +63,12 @@ struct meson_reg_desc {
> * enum meson_reg_type - type of registers encoded in @meson_reg_desc
> */
> enum meson_reg_type {
> - REG_PULLEN,
> - REG_PULL,
> - REG_DIR,
> - REG_OUT,
> - REG_IN,
> - REG_DS,
> + MESON_REG_PULLEN,
> + MESON_REG_PULL,
> + MESON_REG_DIR,
> + MESON_REG_OUT,
> + MESON_REG_IN,
> + MESON_REG_DS,
> NUM_REG,

MESON_NUM_REG?

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds