Re: [PATCH 02/19] context_tracking: Rename context_tracking_user_enter/exit() to user_enter/exit_callable()

From: Peter Zijlstra
Date: Sat Mar 05 2022 - 09:00:40 EST


On Wed, Mar 02, 2022 at 04:47:53PM +0100, Frederic Weisbecker wrote:
> diff --git a/kernel/context_tracking.c b/kernel/context_tracking.c
> index ad2a973393a6..83e050675b23 100644
> --- a/kernel/context_tracking.c
> +++ b/kernel/context_tracking.c
> @@ -125,11 +125,16 @@ void context_tracking_enter(enum ctx_state state)
> NOKPROBE_SYMBOL(context_tracking_enter);
> EXPORT_SYMBOL_GPL(context_tracking_enter);
>
> -void context_tracking_user_enter(void)
> +/**
> + * user_enter_callable() - Unfortunate ASM callable version of user_enter() for
> + * archs that didn't manage to check the context tracking
> + * static key from low level code.
> + */
> +void user_enter_callable(void)
> {
> user_enter();
> }
> -NOKPROBE_SYMBOL(context_tracking_user_enter);
> +NOKPROBE_SYMBOL(user_enter_callable);
>
> /**
> * __ct_user_exit - Inform the context tracking that the CPU is
> @@ -182,11 +187,16 @@ void context_tracking_exit(enum ctx_state state)
> NOKPROBE_SYMBOL(context_tracking_exit);
> EXPORT_SYMBOL_GPL(context_tracking_exit);
>
> -void context_tracking_user_exit(void)
> +/**
> + * user_exit_callable() - Unfortunate ASM callable version of user_exit() for
> + * archs that didn't manage to check the context tracking
> + * static key from low level code.
> + */
> +void user_exit_callable(void)
> {
> user_exit();
> }
> -NOKPROBE_SYMBOL(context_tracking_user_exit);
> +NOKPROBE_SYMBOL(user_exit_callable);

I'm thinking all this wants to be noinstr instead of NOKPROBE_SYMBOL..