Re: [PATCH] iio/adc: Use of_device_get_match_data()

From: Jonathan Cameron
Date: Thu Mar 03 2022 - 04:52:56 EST


On Thu, 3 Mar 2022 01:44:45 +0000
cgel.zte@xxxxxxxxx wrote:

> From: Minghao Chi (CGEL ZTE) <chi.minghao@xxxxxxxxxx>
>
> Use of_device_get_match_data() to simplify the code.

Hi

Thanks for the patch.

Please use the local naming convention for patches, so this should be:

iio: adc: twl6030: Use of_device_get_match_data()

However, we are in process of trying to move all of IIO over to generic
device properties (include/linux/properties.h) and so if we are going
to touch this driver, I'd like to see that change made.

Looks straight forwards with
device_get_match_data() being used here and dropping of_ specific headers
in favour of
linux/properties.h
linux/mod_devicetable.h

If you can make that change it would be great!

Thanks,

Jonathan


>
> Reported-by: Zeal Robot <zealci@xxxxxxxxxx>
> Signed-off-by: Minghao Chi (CGEL ZTE) <chi.minghao@xxxxxxxxxx>
> ---
> drivers/iio/adc/twl6030-gpadc.c | 7 +------
> 1 file changed, 1 insertion(+), 6 deletions(-)
>
> diff --git a/drivers/iio/adc/twl6030-gpadc.c b/drivers/iio/adc/twl6030-gpadc.c
> index afdb59e0b526..6a022e583658 100644
> --- a/drivers/iio/adc/twl6030-gpadc.c
> +++ b/drivers/iio/adc/twl6030-gpadc.c
> @@ -867,16 +867,11 @@ static int twl6030_gpadc_probe(struct platform_device *pdev)
> struct device *dev = &pdev->dev;
> struct twl6030_gpadc_data *gpadc;
> const struct twl6030_gpadc_platform_data *pdata;
> - const struct of_device_id *match;
> struct iio_dev *indio_dev;
> int irq;
> int ret;
>
> - match = of_match_device(of_twl6030_match_tbl, dev);
> - if (!match)
> - return -EINVAL;
> -
> - pdata = match->data;
> + pdata = of_device_get_match_data(dev);
>
> indio_dev = devm_iio_device_alloc(dev, sizeof(*gpadc));
> if (!indio_dev)