Re: [PATCH bpf-next] libbpf: Add a check to ensure that page_cnt is non-zero

From: Andrii Nakryiko
Date: Wed Mar 02 2022 - 19:00:40 EST


On Tue, Mar 1, 2022 at 8:57 AM Yuntao Wang <ytcoode@xxxxxxxxx> wrote:
>
> The page_cnt parameter is used to specify the number of memory pages
> allocated for each per-CPU buffer, it must be non-zero and a power of 2.
>
> Currently, the __perf_buffer__new() function attempts to validate that
> the page_cnt is a power of 2 but forgets checking for the case where
> page_cnt is zero, we can fix it by replacing 'page_cnt & (page_cnt - 1)'
> with '!is_power_of_2(page_cnt)'.
>
> Thus we also don't need to add a check in perf_buffer__new_v0_6_0() to
> make sure that page_cnt is non-zero and the check for zero in
> perf_buffer__new_raw_v0_6_0() can also be removed.
>
> The code is cleaner and more readable.
>
> Signed-off-by: Yuntao Wang <ytcoode@xxxxxxxxx>
> ---
> tools/lib/bpf/libbpf.c | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/tools/lib/bpf/libbpf.c b/tools/lib/bpf/libbpf.c
> index be6480e260c4..4dd1d82cd5b9 100644
> --- a/tools/lib/bpf/libbpf.c
> +++ b/tools/lib/bpf/libbpf.c
> @@ -33,6 +33,7 @@
> #include <linux/filter.h>
> #include <linux/list.h>
> #include <linux/limits.h>
> +#include <linux/log2.h>

we don't have this header implemented in Github repo, so this will be
unnecessary painful


> #include <linux/perf_event.h>
> #include <linux/ring_buffer.h>
> #include <linux/version.h>
> @@ -10951,7 +10952,7 @@ struct perf_buffer *perf_buffer__new_raw_v0_6_0(int map_fd, size_t page_cnt,
> {
> struct perf_buffer_params p = {};
>
> - if (page_cnt == 0 || !attr)
> + if (!attr)
> return libbpf_err_ptr(-EINVAL);
>
> if (!OPTS_VALID(opts, perf_buffer_raw_opts))
> @@ -10992,7 +10993,7 @@ static struct perf_buffer *__perf_buffer__new(int map_fd, size_t page_cnt,
> __u32 map_info_len;
> int err, i, j, n;
>
> - if (page_cnt & (page_cnt - 1)) {
> + if (!is_power_of_2(page_cnt)) {

so let's instead just use `page_cnt == 0 || (page_cnt & (page_cnt -
1))` here explicitly

> pr_warn("page count should be power of two, but is %zu\n",
> page_cnt);
> return ERR_PTR(-EINVAL);
> --
> 2.35.1
>