[PATCH] x86/build: use the proper name CONFIG_FW_LOADER

From: Lukas Bulwahn
Date: Wed Dec 29 2021 - 06:16:12 EST


Commit c8dcf655ec81 ("x86/build: Tuck away built-in firmware under
FW_LOADER") intends to add the expression regex only when FW_LOADER is
built-in, not a module or disabled.

The config is called CONFIG_FW_LOADER when it is built-in; and
CONFIG_FW_LOADER_MODULE when it is a module.

So, adjust the condition to the actual name of the config.

Fixes: c8dcf655ec81 ("x86/build: Tuck away built-in firmware under FW_LOADER")
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@xxxxxxxxx>
---

I am wondering if this regular expression needs to be made differently
depending on the build configuration at all.

Could this not just be added unconditionally anyway or is not needed at all?
It seems that is was broken since its initial inclusion and nobody ever noticed.


arch/x86/tools/relocs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/x86/tools/relocs.c b/arch/x86/tools/relocs.c
index c736cf2ac76b..e2c5b296120d 100644
--- a/arch/x86/tools/relocs.c
+++ b/arch/x86/tools/relocs.c
@@ -68,7 +68,7 @@ static const char * const sym_regex_kernel[S_NSYMTYPES] = {
"(__parainstructions|__alt_instructions)(_end)?|"
"(__iommu_table|__apicdrivers|__smp_locks)(_end)?|"
"__(start|end)_pci_.*|"
-#if CONFIG_FW_LOADER_BUILTIN
+#if CONFIG_FW_LOADER
"__(start|end)_builtin_fw|"
#endif
"__(start|stop)___ksymtab(_gpl)?|"
--
2.17.1