Re: [PATCH v4 14/20] mfd: intel_soc_pmic_chtwc: Add cht_wc_model data to struct intel_soc_pmic

From: Andy Shevchenko
Date: Mon Dec 06 2021 - 17:05:46 EST


On Mon, Dec 6, 2021 at 11:46 PM Hans de Goede <hdegoede@xxxxxxxxxx> wrote:
> On 12/6/21 20:55, Andy Shevchenko wrote:
> > On Mon, Dec 6, 2021 at 11:35 AM Hans de Goede <hdegoede@xxxxxxxxxx> wrote:
> >>
> >> Tablet / laptop designs using an Intel Cherry Trail x86 main SoC with
> >> an Intel Whiskey Cove PMIC do not use a single standard setup for
> >> the charger, fuel-gauge and other chips surrounding the PMIC /
> >> charging+data USB port.
> >>
> >> Unlike what is normal on x86 this diversity in designs is not handled
> >> by the ACPI tables. On 2 of the 3 known designs there are no standard
> >> (PNP0C0A) ACPI battery devices and on the 3th design the ACPI battery
> >> device does not work under Linux due to it requiring non-standard
> >> and undocumented ACPI behavior.
> >>
> >> So to make things work under Linux we use native charger and fuel-gauge
> >> drivers on these devices, re-using the native drivers used on ARM boards
> >> with the same charger / fuel-gauge ICs.
> >>
> >> This requires various MFD-cell drivers for the CHT-WC PMIC cells to
> >> know which model they are exactly running on so that they can e.g.
> >> instantiate an I2C-client for the right model charger-IC (the charger
> >> is connected to an I2C-controller which is part of the PMIC).
> >>
> >> Rather then duplicating DMI-id matching to check which model we are
> >> running on in each MFD-cell driver, add a check for this to the
> >> shared drivers/mfd/intel_soc_pmic_chtwc.c code by using a
> >> DMI table for all 3 known models:
> >>
> >> 1. The GPD Win and GPD Pocket mini-laptops, these are really 2 models
> >> but the Pocket re-uses the GPD Win's design in a different housing:
> >>
> >> The WC PMIC is connected to a TI BQ24292i charger, paired with
> >> a Maxim MAX17047 fuelgauge + a FUSB302 USB Type-C Controller +
> >> a PI3USB30532 USB switch, for a fully functional Type-C port.
> >>
> >> 2. The Xiaomi Mi Pad 2:
> >>
> >> The WC PMIC is connected to a TI BQ25890 charger, paired with
> >> a TI BQ27520 fuelgauge, using the TI BQ25890 for BC1.2 charger type
> >> detection, for a USB-2 only Type-C port without PD.
> >>
> >> 3. The Lenovo Yoga Book YB1-X90 / Lenovo Yoga Book YB1-X91 series:
> >>
> >> The WC PMIC is connected to a TI BQ25892 charger, paired with
> >> a TI BQ27542 fuelgauge, using the WC PMIC for BC1.2 charger type
> >> detection and using the BQ25892's Mediatek Pump Express+ (1.0)
> >> support to enable charging with up to 12V through a micro-USB port.
> >
> > ...
> >
> >> +enum intel_cht_wc_models {
> >> + INTEL_CHT_WC_UNKNOWN,
> >> + INTEL_CHT_WC_GPD_WIN_POCKET,
> >> + INTEL_CHT_WC_XIAOMI_MIPAD2,
> >> + INTEL_CHT_WC_LENOVO_YOGABOOK1,
> >> +};
> >
> > ...
> >
> >> + enum intel_cht_wc_models cht_wc_model;
> >
> > I'm wondering what will you do when something similar will be needed
> > for another PMIC?
> >
> > I see possible solutions to eliminate additional churn:
> > - make just one enum for all models (can be done now, can be renamed later)
> > - make a union if we have such situation
> >
> > because I wouldn't like to have another field for each possible
> > variant of PMIC in the generic structure.
> >
> > Hence the question, does it make sense to just name it (enum and
> > member) less cht_wc oriented?
>
> I agree that renaming these to make them generic makes sense if we get a
> second user (which I doubt, but you never know). For now I would like to
> keep this as is though, this is a big series and I would like to avoid
> to respin it just for this and we can always rename this later.
>
> If I need to do a v5 anyways though, then I'll do the rename for v5.

Yeah, either way:
Reviewed-by: Andy Shevchenko <andy.shevchenko@xxxxxxxxx>

--
With Best Regards,
Andy Shevchenko