Re: [PATCH] edac,ghes,cper: Add device to Memory Error Record

From: Shuai Xue
Date: Thu Dec 02 2021 - 08:32:35 EST


Hi, Tony,

> This looks OK (same as code in drivers/firmware/efi/cper.c in the
> cper_mem_err_location() function. But that makes me wonder why there
> is near duplication of code in ghes_edac.c?
May it is a legacy issue.


> The cper.c code seems to be written defensively using scnprintf()
> instead of sprintf(). Could ghes_edac share the same code?
I think so, ghes_edac_report_mem_error in ghes_edac.c is Long Method
and have Duplicated Code with cper_mem_err_location,
cper_dimm_err_location, and cper_mem_err_type_str in
drivers/firmware/efi/cper.c.

I will send a new patch to rework ghes_edac_report_mem_error.

Cheers
Shuai

On 2021/12/1 AM3:13, Luck, Tony wrote:
> On Tue, Nov 30, 2021 at 09:16:48PM +0800, Shuai Xue wrote:
>> If Bit 7 of Validation Bits is valid, the device number of the memory
>> associated with errors should be reported to Memory Error Record.
>>
>> Signed-off-by: Shuai Xue <xueshuai@xxxxxxxxxxxxxxxxx>
>> ---
>> drivers/edac/ghes_edac.c | 2 ++
>> 1 file changed, 2 insertions(+)
>>
>> diff --git a/drivers/edac/ghes_edac.c b/drivers/edac/ghes_edac.c
>> index a918ca93e4f7..cf98b270d6f7 100644
>> --- a/drivers/edac/ghes_edac.c
>> +++ b/drivers/edac/ghes_edac.c
>> @@ -378,6 +378,8 @@ void ghes_edac_report_mem_error(int sev, struct cper_sec_mem_err *mem_err)
>> if (mem_err->validation_bits & CPER_MEM_VALID_BANK_ADDRESS)
>> p += sprintf(p, "bank_address:%d ",
>> mem_err->bank & CPER_MEM_BANK_ADDRESS_MASK);
>> + if (mem_err->validation_bits & CPER_MEM_VALID_DEVICE)
>> + p += sprintf(p, "device:%d ", mem_err->device);
>> if (mem_err->validation_bits & (CPER_MEM_VALID_ROW | CPER_MEM_VALID_ROW_EXT)) {
>> u32 row = mem_err->row;
>>
>
> This looks OK (same as code in drivers/firmware/efi/cper.c in the
> cper_mem_err_location() function. But that makes me wonder why there
> is near duplication of code in ghes_edac.c?
>
> The cper.c code seems to be written defensively using scnprintf()
> instead of sprintf(). Could ghes_edac share the same code?
>
> -Tony
>