Re: [PATCH v3 05/14] ARM: tegra: Add device-tree for ASUS Transformer Prime TF201

From: Michał Mirosław
Date: Sat Nov 27 2021 - 20:53:42 EST


On Sat, Nov 27, 2021 at 05:23:18PM +0300, Dmitry Osipenko wrote:
> From: Svyatoslav Ryhel <clamor95@xxxxxxxxx>
>
> Add device-tree for ASUS Transformer Prime TF201, which is NVIDIA
> Tegra30-based tablet device.
>
> Co-developed-by: Ion Agorria <ion@xxxxxxxxxxx>
> Signed-off-by: Ion Agorria <ion@xxxxxxxxxxx>
> Co-developed-by: Maxim Schwalm <maxim.schwalm@xxxxxxxxx>
> Signed-off-by: Maxim Schwalm <maxim.schwalm@xxxxxxxxx>
> Signed-off-by: Svyatoslav Ryhel <clamor95@xxxxxxxxx>
> ---
> arch/arm/boot/dts/Makefile | 1 +
> .../boot/dts/tegra30-asus-lvds-display.dtsi | 46 +
> arch/arm/boot/dts/tegra30-asus-tf201.dts | 623 ++++++
> .../dts/tegra30-asus-transformer-common.dtsi | 1741 +++++++++++++++++
> 4 files changed, 2411 insertions(+)
> create mode 100644 arch/arm/boot/dts/tegra30-asus-lvds-display.dtsi
> create mode 100644 arch/arm/boot/dts/tegra30-asus-tf201.dts
> create mode 100644 arch/arm/boot/dts/tegra30-asus-transformer-common.dtsi

I think the common.dtsi is combined from all the DT authors, so they all
should be mentioned in the co-developed/signed-off lines. (Or maybe just
split the common part out if you want to be more specific in assigning
credits?)


> + i2c@7000c400 {
> + /* Atmel MXT768E touchscreen */
> + touchscreen@4d {
[...]
> + interrupt-parent = <&gpio>;
> + interrupts = <TEGRA_GPIO(H, 4) IRQ_TYPE_EDGE_FALLING>;
[...]

Nit: This could use 'interrupts-extended' as it's more readable, I think.
(There are similar cases in other DTs.)

> + uartb: serial@70006040 {
> + compatible = "nvidia,tegra30-hsuart";
[...]

I wonder why isn't this in the tegra30.dtsi? The DT shouldn't select a
driver - it should only describe the hardware.

Best Regards
Michał Mirosław