Re: [PATCH] scripts/tags: merge "TAGS" and "tags" in case

From: Zackary Liu
Date: Fri Nov 26 2021 - 21:28:46 EST



On Nov 26 2021, at 11:58 pm, Greg KH <gregkh@xxxxxxxxxxxxxxxxxxx> wrote:

> On Wed, Nov 03, 2021 at 11:35:29PM +0800, Zhaoyu Liu wrote:
>> merge "TAGS" and "tags" for the code more concise
>>
>> Signed-off-by: Zhaoyu Liu <zackary.liu.pro@xxxxxxxxx>
>> ---
>> scripts/tags.sh | 14 +++++---------
>> 1 file changed, 5 insertions(+), 9 deletions(-)
>>
>> diff --git a/scripts/tags.sh b/scripts/tags.sh
>> index 16d475b3e203..a9181dd0fee2 100755
>> --- a/scripts/tags.sh
>> +++ b/scripts/tags.sh
>> @@ -315,15 +315,11 @@ case "$1" in
>> dogtags
>> ;;
>>
>> - "tags")
>> - rm -f tags
>> - xtags ctags
>> - remove_structs=y
>> - ;;
>> -
>> - "TAGS")
>> - rm -f TAGS
>> - xtags etags
>> + "TAGS" | "tags")
>> + rm -f $1
>> + xtags $([ $1 = "tags" ] \
>> + && echo ctags \
>> + || echo etags)
>> remove_structs=y
>> ;;
>
> Ick, that's much harder to read and understand.
>
> What is wrong with the existing code? It's obvious and makes sense, it
> is not duplicating any lines here except the one "remove_structs=y"
> which is fine.
>
> I'm not going to take this, sorry.
>
> greg k-h
>

Ok you're right, Easy to understand is better.
Thank you.

zackary