[PATCH] devlink: use min() to make code cleaner

From: cgel . zte
Date: Thu Nov 25 2021 - 02:15:42 EST


From: Lv Ruyi <lv.ruyi@xxxxxxxxxx>

Use the macro 'min()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Reported-by: Zeal Robot <zealci@xxxxxxxxxx>
Signed-off-by: Lv Ruyi <lv.ruyi@xxxxxxxxxx>
---
net/core/devlink.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/net/core/devlink.c b/net/core/devlink.c
index d144a62cbf73..6ffbbb02fb91 100644
--- a/net/core/devlink.c
+++ b/net/core/devlink.c
@@ -9,6 +9,7 @@

#include <linux/kernel.h>
#include <linux/module.h>
+#include <linux/minmax.h>
#include <linux/types.h>
#include <linux/slab.h>
#include <linux/gfp.h>
@@ -5763,10 +5764,7 @@ static int devlink_nl_region_read_snapshot_fill(struct sk_buff *skb,
u32 data_size;
u8 *data;

- if (end_offset - curr_offset < DEVLINK_REGION_READ_CHUNK_SIZE)
- data_size = end_offset - curr_offset;
- else
- data_size = DEVLINK_REGION_READ_CHUNK_SIZE;
+ data_size = min(end_offset - curr_offset, DEVLINK_REGION_READ_CHUNK_SIZE);

data = &snapshot->data[curr_offset];
err = devlink_nl_cmd_region_read_chunk_fill(skb, devlink,
--
2.25.1