Re: [PATCH net-next] net: bridge: make use of helper netif_is_bridge_master()

From: Jakub Kicinski
Date: Wed Oct 13 2021 - 16:33:35 EST


On Tue, 12 Oct 2021 23:18:09 +0900 Kyungrok Chung wrote:
> Make use of netdev helper functions to improve code readability.
> Replace 'dev->priv_flags & IFF_EBRIDGE' with netif_is_bridge_master(dev).
>
> Signed-off-by: Kyungrok Chung <acadx0@xxxxxxxxx>

Why leave these out?

net/batman-adv/multicast.c: } while (upper && !(upper->priv_flags & IFF_EBRIDGE));
net/core/rtnetlink.c: !(dev->priv_flags & IFF_EBRIDGE))