Re: [PATCH net-next 1/7] page_pool: disable dma mapping support for 32-bit arch with 64-bit DMA

From: Yunsheng Lin
Date: Fri Sep 24 2021 - 04:04:08 EST


On 2021/9/24 15:25, Ilias Apalodimas wrote:
> On Fri, 24 Sept 2021 at 10:04, Yunsheng Lin <linyunsheng@xxxxxxxxxx> wrote:
>>
>> On 2021/9/23 21:07, Ilias Apalodimas wrote:
>>> On Thu, Sep 23, 2021 at 07:13:11PM +0800, Yunsheng Lin wrote:
>>>> On 2021/9/23 18:02, Ilias Apalodimas wrote:
>>>>> Hi Jesper,
>>>>>
>>>>> On Thu, 23 Sept 2021 at 12:33, Jesper Dangaard Brouer
>>>>> <jbrouer@xxxxxxxxxx> wrote:
>>>>>>
>>>>>>
>>>>>> On 22/09/2021 11.41, Yunsheng Lin wrote:
>>>>>>> diff --git a/net/core/page_pool.c b/net/core/page_pool.c
>>>>>>> index 1a6978427d6c..a65bd7972e37 100644
>>>>>>> --- a/net/core/page_pool.c
>>>>>>> +++ b/net/core/page_pool.c
>>>>>>> @@ -49,6 +49,12 @@ static int page_pool_init(struct page_pool *pool,
>>>>>>> * which is the XDP_TX use-case.
>>>>>>> */
>>>>>>> if (pool->p.flags & PP_FLAG_DMA_MAP) {
>>>>>>> + /* DMA-mapping is not supported on 32-bit systems with
>>>>>>> + * 64-bit DMA mapping.
>>>>>>> + */
>>>>>>> + if (sizeof(dma_addr_t) > sizeof(unsigned long))
>>>>>>> + return -EINVAL;
>>>>>>
>>>>>> As I said before, can we please use another error than EINVAL.
>>>>>> We should give drivers a chance/ability to detect this error, and e.g.
>>>>>> fallback to doing DMA mappings inside driver instead.
>>>>>>
>>>>>> I suggest using EOPNOTSUPP 95 (Operation not supported).
>>>>
>>>> Will change it to EOPNOTSUPP, thanks.
>>>
>>> Mind sending this one separately (and you can keep my reviewed-by). It
>>> fits nicely on it's own and since I am not sure about the rest of the
>>> changes yet, it would be nice to get this one in.
>>
>> I am not sure sending this one separately really makes sense, as it is
>> mainly used to make supporting the "keep track of pp page when __skb_frag_ref()
>> is called" in patch 5 easier.
>
> It rips out support for devices that are 32bit and have 64bit dma and
> make the whole code easier to follow. I thought we agreed on removing
> the support for those devices regardless didn't we?

I am actually not convinced that the code about PAGE_POOL_DMA_USE_PP_FRAG_COUNT
(maybe the name is somewhat confusiong) as it it now, but it is after adding patch
5, and it seems we are not handing the skb_split() case in tso_fragment() for 32bit
arch with 64bit dma too if we still keep PAGE_POOL_DMA_USE_PP_FRAG_COUNT macro.


>
> Regards
> /Ilias
> .
>