Re: [PATCH 1/3] drm/etnaviv: use PLATFORM_DEVID_NONE

From: Christian Gmeiner
Date: Thu Aug 26 2021 - 09:00:19 EST


Am Do., 26. Aug. 2021 um 14:10 Uhr schrieb Michael Walle <michael@xxxxxxxx>:
>
> There is already a macro for the magic value. Use it.
>
> Signed-off-by: Michael Walle <michael@xxxxxxxx>

Reviewed-by: Christian Gmeiner <christian.gmeiner@xxxxxxxxx>

I will wait for v2 for the rest of the changes to review.

> ---
> drivers/gpu/drm/etnaviv/etnaviv_drv.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/etnaviv/etnaviv_drv.c b/drivers/gpu/drm/etnaviv/etnaviv_drv.c
> index 7dcc6392792d..2509b3e85709 100644
> --- a/drivers/gpu/drm/etnaviv/etnaviv_drv.c
> +++ b/drivers/gpu/drm/etnaviv/etnaviv_drv.c
> @@ -653,7 +653,7 @@ static int __init etnaviv_init(void)
> if (!of_device_is_available(np))
> continue;
>
> - pdev = platform_device_alloc("etnaviv", -1);
> + pdev = platform_device_alloc("etnaviv", PLATFORM_DEVID_NONE);
> if (!pdev) {
> ret = -ENOMEM;
> of_node_put(np);
> --
> 2.30.2
>


--
greets
--
Christian Gmeiner, MSc

https://christian-gmeiner.info/privacypolicy