Re: [PATCH linux-next] PCI: Fix the order in unregister path

From: Rob Herring
Date: Thu Aug 26 2021 - 08:01:31 EST


On Wed, Aug 25, 2021 at 10:57 PM <yajun.deng@xxxxxxxxx> wrote:
>
> August 25, 2021 9:55 PM, "Rob Herring" <robh@xxxxxxxxxx> wrote:
>
> > On Wed, Aug 25, 2021 at 3:34 AM Yajun Deng <yajun.deng@xxxxxxxxx> wrote:
> >
> >> device_del() should be called first and then called put_device() in
> >> unregister path, becase if that the final reference count, the device
> >> will be cleaned up via device_release() above. So use device_unregister()
> >> instead.
> >>
> >> Fixes: 9885440b16b8 (PCI: Fix pci_host_bridge struct device release/free handling)
> >> Signed-off-by: Yajun Deng <yajun.deng@xxxxxxxxx>
> >> ---
> >> drivers/pci/probe.c | 4 +---
> >> 1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > NAK.
> >
> > The current code is correct. Go read the comments for device_add/device_del.
>
> But the device_unregister() is only contains device_del() and put_device(). It just put
> device_del() before put_device().

And that is the wrong order as we want to undo what the code above
did. The put_device here is for the get_device we did. The put_device
in device_unregister is for the get_device that device_register did
(on success only).

Logically, it is wrong too to call unregister if register failed. That
would be like doing this:

p = malloc(1);
if (!p)
free(p);

Rob