Re: [PATCH v3 19/21] KVM: arm64: Refactor protected nVHE stage-1 locking

From: Fuad Tabba
Date: Tue Aug 03 2021 - 06:51:57 EST


Hi Quentin,

> > > +int pkvm_create_mappings(void *from, void *to, enum kvm_pgtable_prot prot)
> > > +{
> > > + int ret;
> > > +
> > > + hyp_spin_lock(&pkvm_pgd_lock);
> > > + ret = pkvm_create_mappings_locked(from, to, prot);
> > > + hyp_spin_unlock(&pkvm_pgd_lock);
> > > +
> > > + return ret;
> > > +}
> > > +
> >
> > I'm wondering whether this patch should also refactor
> > __pkvm_create_mappings. It doesn't quite do the exact same thing and
> > has different parameters.
>
> Sorry, not sure I'm understanding your suggestion here. What do you
> think should be done to __pkvm_create_mappings?

Sorry, my comment wasn't very clear, and "refactor" is the wrong word.
I think it should probably be renamed, because __pkvm_create_mappings
isn't called by pkvm_create_mappings nor by
pkvm_create_mappings_locked. It also has different parameters and
behaves slightly differently.

Thanks,
/fuad

> Cheers,
> Quentin