[PATCH v1 1/1] spi: Remove unneeded parentheses in spi_map_buf()

From: Andy Shevchenko
Date: Sat Jun 19 2021 - 07:15:10 EST


The boolean expression to get kmap_buf is hard to read due to
too many unneeded parentheses. Remove them for good.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
---
drivers/spi/spi.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/drivers/spi/spi.c b/drivers/spi/spi.c
index 16b377581d16..0e4917a55eaa 100644
--- a/drivers/spi/spi.c
+++ b/drivers/spi/spi.c
@@ -873,9 +873,8 @@ int spi_map_buf(struct spi_controller *ctlr, struct device *dev,
const bool vmalloced_buf = is_vmalloc_addr(buf);
unsigned int max_seg_size = dma_get_max_seg_size(dev);
#ifdef CONFIG_HIGHMEM
- const bool kmap_buf = ((unsigned long)buf >= PKMAP_BASE &&
- (unsigned long)buf < (PKMAP_BASE +
- (LAST_PKMAP * PAGE_SIZE)));
+ const bool kmap_buf = (unsigned long)buf >= PKMAP_BASE &&
+ (unsigned long)buf < (PKMAP_BASE + LAST_PKMAP * PAGE_SIZE);
#else
const bool kmap_buf = false;
#endif
--
2.30.2