Re: [PATCH 1/2] crypto: af_alg - use DIV_ROUND_UP helper macro for calculations

From: Christophe Leroy
Date: Tue May 25 2021 - 04:34:19 EST


Wu Bo <wubo40@xxxxxxxxxx> a écrit :

From: Wu Bo <wubo40@xxxxxxxxxx>

Replace open coded divisor calculations with the DIV_ROUND_UP kernel
macro for better readability.

Signed-off-by: Wu Bo <wubo40@xxxxxxxxxx>
---
crypto/af_alg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/crypto/af_alg.c b/crypto/af_alg.c
index 18cc82d..8bd288d 100644
--- a/crypto/af_alg.c
+++ b/crypto/af_alg.c
@@ -411,7 +411,7 @@ int af_alg_make_sg(struct af_alg_sgl *sgl, struct iov_iter *iter, int len)
if (n < 0)
return n;

- npages = (off + n + PAGE_SIZE - 1) >> PAGE_SHIFT;
+ npages = DIV_ROUND_UP(off + n, PAGE_SIZE);

You should use PFN_UP()

if (WARN_ON(npages == 0))
return -EINVAL;
/* Add one extra for linking */
--
1.8.3.1