Re: [PATCH][next] gpio: xilinx: Fix potential integer overflow on shift of a u32 int

From: Dan Carpenter
Date: Fri May 14 2021 - 01:38:57 EST


On Thu, May 13, 2021 at 09:52:27AM +0100, Colin King wrote:
> From: Colin Ian King <colin.king@xxxxxxxxxxxxx>
>
> The left shift of the u32 integer v is evaluated using 32 bit
> arithmetic and then assigned to a u64 integer. There are cases
> where v will currently overflow on the shift. Avoid this by
> casting it to unsigned long (same type as map[]) before shifting
> it.
>
> Addresses-Coverity: ("Unintentional integer overflow")
> Fixes: 02b3f84d9080 ("gpio: xilinx: Switch to use bitmap APIs")
> Signed-off-by: Colin Ian King <colin.king@xxxxxxxxxxxxx>
> ---
> drivers/gpio/gpio-xilinx.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpio/gpio-xilinx.c b/drivers/gpio/gpio-xilinx.c
> index 109b32104867..164a3a5a9393 100644
> --- a/drivers/gpio/gpio-xilinx.c
> +++ b/drivers/gpio/gpio-xilinx.c
> @@ -99,7 +99,7 @@ static inline void xgpio_set_value32(unsigned long *map, int bit, u32 v)
> const unsigned long offset = (bit % BITS_PER_LONG) & BIT(5);
>
> map[index] &= ~(0xFFFFFFFFul << offset);
> - map[index] |= v << offset;
> + map[index] |= (unsigned long)v << offset;

Doing a shift by BIT(5) is super weird. It looks like a double shift
bug and should probably trigger a static checker warning. It's like
when people do BIT(BIT(5)).

It would be more readable to write it as:

int shift = (bit % BITS_PER_LONG) ? 32 : 0;

regards,
dan carpenter