[PATCH v2 0/5] kvfree_rcu() miscellaneous fixes

From: Uladzislau Rezki (Sony)
Date: Thu Apr 15 2021 - 13:20:15 EST


This is a v2 of a small series. See the changelog below:

V1 -> V2:
- document the rcu_delay_page_cache_fill_msec parameter;
- drop the "kvfree_rcu: introduce "flags" variable" patch;
- reword commit messages;
- in the patch [1], do not use READ_ONCE() instances in
get_cached_bnode()/put_cached_bnode() it is protected
by the lock.
- Capitalize the word following by ":" in commit messages.

Uladzislau Rezki (Sony) (4):
[1] kvfree_rcu: Use [READ/WRITE]_ONCE() macros to access to nr_bkv_objs
[2] kvfree_rcu: Add a bulk-list check when a scheduler is run
[3] kvfree_rcu: Update "monitor_todo" once a batch is started
[4] kvfree_rcu: Use kfree_rcu_monitor() instead of open-coded variant

Zhang Qiang (1):
[5] kvfree_rcu: Release a page cache under memory pressure

.../admin-guide/kernel-parameters.txt | 5 +
kernel/rcu/tree.c | 92 +++++++++++++++----
2 files changed, 77 insertions(+), 20 deletions(-)

--
2.20.1