[PATCH 6/6] kvfree_rcu: use kfree_rcu_monitor() instead of open-coded variant

From: Uladzislau Rezki (Sony)
Date: Wed Apr 14 2021 - 08:13:02 EST


To queue a new batch we have a kfree_rcu_monitor() function that
checks KRC_MONITOR_TODO bit and invokes kfree_rcu_drain_unlock()
to start a new batch after a GP. Get rid of open-coded case by
switching it to the separate function.

Signed-off-by: Uladzislau Rezki (Sony) <urezki@xxxxxxxxx>
---
kernel/rcu/tree.c | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)

diff --git a/kernel/rcu/tree.c b/kernel/rcu/tree.c
index 012030cbe55e..14e9220198eb 100644
--- a/kernel/rcu/tree.c
+++ b/kernel/rcu/tree.c
@@ -3680,7 +3680,6 @@ static unsigned long
kfree_rcu_shrink_scan(struct shrinker *shrink, struct shrink_control *sc)
{
int cpu, freed = 0;
- unsigned long flags;

for_each_possible_cpu(cpu) {
int count;
@@ -3688,12 +3687,7 @@ kfree_rcu_shrink_scan(struct shrinker *shrink, struct shrink_control *sc)

count = krcp->count;
count += drain_page_cache(krcp);
-
- raw_spin_lock_irqsave(&krcp->lock, flags);
- if (test_bit(KRC_MONITOR_TODO, &krcp->flags))
- kfree_rcu_drain_unlock(krcp, flags);
- else
- raw_spin_unlock_irqrestore(&krcp->lock, flags);
+ kfree_rcu_monitor(&krcp->monitor_work.work);

sc->nr_to_scan -= count;
freed += count;
--
2.20.1