Re: [PATCH] block: Fix sys_ioprio_set(.which=IOPRIO_WHO_PGRP) task iteration

From: Oleg Nesterov
Date: Fri Apr 09 2021 - 06:16:11 EST


On 04/08, Jens Axboe wrote:
>
> On 4/8/21 3:46 AM, Peter Zijlstra wrote:
> >
> > do_each_pid_thread() { } while_each_pid_thread() is a double loop and
> > thus break doesn't work as expected. Also, it should be used under
> > tasklist_lock because otherwise we can race against change_pid() for
> > PGID/SID.
>
> Applied, thanks.

Agreed, but can't resist. We can move the "out" label up and avoid the extra
read_unlock(tasklist_lock). IOW, something like below on top of this patch.

Quite possibly this won't change the generated code, gcc is smart enough, but
this makes the code a bit more readable.

Oleg.

--- x/block/ioprio.c~ 2021-04-09 12:00:28.066145563 +0200
+++ x/block/ioprio.c 2021-04-09 12:02:01.817849618 +0200
@@ -123,11 +123,10 @@
read_lock(&tasklist_lock);
do_each_pid_thread(pgrp, PIDTYPE_PGID, p) {
ret = set_task_ioprio(p, ioprio);
- if (ret) {
- read_unlock(&tasklist_lock);
- goto out;
- }
+ if (ret)
+ goto out_pgrp;
} while_each_pid_thread(pgrp, PIDTYPE_PGID, p);
+out_pgrp:
read_unlock(&tasklist_lock);

break;
@@ -159,7 +158,6 @@
ret = -EINVAL;
}

-out:
rcu_read_unlock();
return ret;
}